bigrushnboss
07.10.2020 07:51

1. составьте блок-схему и программу вычисления значения функции
2. составьте программу, определяющую, является ли данное число делителем числа 3.
3. составьте программу, заменяющую меньшее из двух данных чисел суммой, а большее - произведением этих чисел.
20

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Misha01923
14.05.2023 20:19

Первое поколение. Компьютеры на электронных лампах (194х-1955)

Быстродействие: несколько десятков тысяч операций в секунду.

Компьютер на электронных лампах

Особенности:

Поскольку лампы имеют существенные размеры и их тысячи, то машины имели огромные размеры.

Поскольку ламп много и они имеют свойство перегорать, то часто компьютер простаивал из-за поиска и замены вышедшей из строя лампы.

Лампы выделяют большое количество тепла, следовательно, вычислительные машины требуют специальные мощные охладительные системы.

Примеры компьютеров:

Колоссус – секретная разработка британского правительства (в разработке принимал участие Алан Тьюринг). Это первый в мире электронный компьютер, хотя и не оказавший влияние на развитие компьютерной техники (из-за своей секретности), но победить во Второй мировой войне.

0,0(0 оценок)
Ответ:
DonP3dro
18.05.2021 15:34
// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
begin
  var n:=ReadInteger('Введите четырехзначное число');
  Writeln('В числе');
  Writeln(n div 1000,' - тысяч');
  Writeln((n div 100) mod 10,' - сотен');
  Writeln((n mod 100) div 10,' - десятков');
  Writeln(n mod 10,' - единиц')
end.

Тестовое решение:
Введите четырехзначное число 4072
В числе
4 - тысяч
0 - сотен
7 - десятков
2 - единиц

// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
begin
  var n:=ReadInteger('Введите трехзначное число');
  var s:=n div 100;
  var d:=(n div 10) mod 10;
  var e:=n mod 10;
  Writeln('Sum=',s+d+e);
  Writeln(e,d,s);
  Writeln('В числе');
  Writeln(e,' - сотен');
  Writeln(d,' - десятков');
  Writeln(s,' - единиц')
end.

Тестовое решение:
Введите трехзначное число 492
Sum=15
294
В числе
2 - сотен
9 - десятков
4 - единиц
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота