елизавета4щ
23.02.2020 13:19

Информатика, 8 класс
нарисовать блок-схему и составить программу для нахождения суммы первых n подряд идущих натуральных чисел.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ALENAFOKS
20.05.2020 04:47
1)

Var
A:integer;
S:real;
Begin
{Первый
S:=0;
For A:= 1 to 50 do
    S:=S+1/A;
WriteLn('S = ',S);
{Второй
S:=0;
A:=1;
Repeat
S:=S+1/A;
A:=A+1;
Until A>50;
WriteLn('S = ',S);
{Третий
S:=0;
A:=1;
While A<=50 do
   Begin
   S:=S+1/A;
   A:=A+1;
   End;
WriteLn('S = ',S)
End.

Var
x:real;
Begin
x:=-3;
Repeat
WriteLn('y(',x,') = ',((3*x*x-2)/4):0:3);
x:=x+0.2
Until x>3.2;
End.

Var
A:real;
k,i:integer;
Begin
k:=0;
WriteLn('Введите десять чисел');
For i:= 1 to 10 do
    Begin
    Read(A);
    if A<0 then k:=k+1
    End;
WriteLn('k = ',k)
End.
0,0(0 оценок)
Ответ:
милана36
20.05.2020 04:47
1)

Var
A:integer;
S:real;
Begin
{Первый
S:=0;
For A:= 1 to 50 do
    S:=S+1/A;
WriteLn('S = ',S);
{Второй
S:=0;
A:=1;
Repeat
S:=S+1/A;
A:=A+1;
Until A>50;
WriteLn('S = ',S);
{Третий
S:=0;
A:=1;
While A<=50 do
   Begin
   S:=S+1/A;
   A:=A+1;
   End;
WriteLn('S = ',S)
End.

Var
x:real;
Begin
x:=-3;
Repeat
WriteLn('y(',x,') = ',((3*x*x-2)/4):0:3);
x:=x+0.2
Until x>3.2;
End.

Var
A:real;
k,i:integer;
Begin
k:=0;
WriteLn('Введите десять чисел');
For i:= 1 to 10 do
    Begin
    Read(A);
    if A<0 then k:=k+1
    End;
WriteLn('k = ',k)
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота