fogive
10.07.2021 15:02

Составить программу на языке pascal для решения следующей : дана строка. заменить в этой строке все буквы «о» на буквы «а». если букв «о» не встречено в строке, то вывести на экран сообщение «нет буквы «о»

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
АнастасияКот26
04.01.2023 19:30

Вы не указали на каком языке Вам необходимо это решить. Поэтому выкладываю решение на C#.

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

 

namespace ConsoleApplication1

{

class Program

{

static double[] Solve(double A, double B, double C, out bool Fail)

{

Fail = false;

double D = B * B - A * C;

double[] res = new double[2];

if (D >= 0)

{

res[0] = (Math.Sqrt(D) + B) / (2 * A);

res[1] = (Math.Sqrt(D) - B) / (2 * A);

}

else

{

Fail = true;

}

return res;

}

static void Main(string[] args)

{

bool Fail = false;

Console.WriteLine("Введите коэффициент при x^2");

double A = Double.Parse(Console.ReadLine());

Console.WriteLine("Введите коэффициент при x");

double B = Double.Parse(Console.ReadLine());

Console.WriteLine("Введите свободный коэффициент");

double C = Double.Parse(Console.ReadLine());

double[] res = Solve(A, B, C, out Fail);

if (Fail)

{

Console.Write("Дискриминант меньше нуля\n");

}

else

{

for (int i = 0; i < res.Length; i++)

{

Console.Write("x{0}={1} ", i, res[i]);

}

Console.Write("\n");

}

}

}

}

0,0(0 оценок)
Ответ:
янакуницкая2017
02.04.2020 01:00
Var x1,y1,x2,y2,v1,v2:real;
begin
  writeln("введите количество метров пробегания жирафа");
  read(y1);
  writeln("введите, за сколько секунд он должен пробежать");
  read(x1);
  writeln("введите количество метров пробегания зайца");
  read(y2);
  writeln("введите, за сколько секунд он должен пробежать");
  read(x2);
  v1:=y1/x1;
  v2:=y2/x2;
  if v1>v2 then 
  begin
     writeln("жираф чемпион");
  end
  else if v1<v2 then 
  begin
     writeln("заяц чемпион");
  end
  else
  begin
    writeln("победила дружба);
  end;
end;
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота