сымбат64
06.05.2022 05:45

Паскаль: дан массив целых чисел. элементы массива вводятся с клавиатуры. вывести на экран все четные элементы этого массива.

составить программу​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Ivankozyr69gmail
10.12.2021 12:12
В основу решения возьму тот факт, что точка лежит внутри треугольника только в том случае, если сумма площадей трех образованных этой точкой и вершинами треугольников треугольников равна площади самого треугольника. Для нахождения площади треугольников использую формулу векторного произведения, деленного пополам.

#include <stdio.h>
#include <stdlib.h>

using namespace std;

int main() {
  int x1, y1, x2, y2, x3, y3, x0, y0;
  scanf("%d%d%d%d%d%d%d%d", &x1, &y1, &x2, &y2, &x3, &y3, &x0, &y0);
  if (abs((x1 - x0) * (y2 - y0) - (x2 - x0) * (y1 - y0)) +
      abs((x1 - x3) * (y0 - y3) - (x0 - x3) * (y1 - y3)) +
      abs((x0 - x3) * (y2 - y3) - (x2 - x3) * (y0 - y3)) ==
      abs((x1 - x3) * (y2 - y3) - (x2 - x3) * (y1 - y3)))
  {
    printf("YES");
  } else {
    printf("NO");
  }
  return 0;
}
0,0(0 оценок)
Ответ:
котяточка
29.05.2023 02:16

#arr = [*map(int, input().split(' 0')[0].split())]  если числа вводятся в строчку , то раскомментируйте и используйте эту строку, а инициализацию массива arr и цикл while закомментируйте

arr = []

while 1:

   tmp = int(input())

   if tmp != 0:  # Читаем сколько угодно чисел пока не будет ноль

       arr.append(tmp)

   else:

       break

s = 0  # сумма двузначных чисел

k = 0  # количество двузначных чисел

for i in arr:

   if 10 <= i <= 99:  # итерируемся по циклу и если число двузначное

       s += i  # то прибавляем его к сумме

       k += 1  # счетчик двузначный чисел увеличиваем на один

print(s/k) if k > 0 else print('NO') #если количество двузначных > 0 то выводим среднее арифметическое s/k, если нет то выводим NO

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота