MashaBelous
31.05.2022 13:58

Напишите программу для нахождения минимальной и максимальной цифры в числе.язык c++

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Gudimnik1
10.10.2020 19:39

#include <iostream>

#define max 100

using namespace std;

int index;

char input = 0;

int ln;

char min = '9' + 1;

char max = '0';

int nul;

int main()

{

   cin >> input;

   

   for(int j = 0; input[j] != '\0'; j++){

       ln = j + 1;

   }

   

   for(int j = 0; j < ln ; j++){

       if( input[j] < min){

           min = input[j];

       }

   }

   

   for(int j = 0; j < ln ; j++){

       if (input[j] > max){

           max = input[j];

       }

   }

   cout << "max:" <<  max;

   cout << "min:" << min;

   cin >> nul;

   

   return 0;

}

P.S.я не уверен, если у тебя не запуститься пиши

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота