SHiiimochka
14.06.2021 19:53

Написать программу,которая определяет в массиве количество чисел кратных 4 и выписывает наибольшее из них

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
карамелька5555
19.09.2021 20:54

Не бейте, я не знаю, что я написал. Надеюсь, тебе это .

#include <iostream>

#include <vector>

using namespace std;

template<typename a, typename b>

class myPair {

public:

myPair(a first, b second) : first(first), second(second) {

}

myPair operator+(myPair a) {

 return myPair(first + a.first, second + a.second);

}

myPair operator-(myPair a) {

 return operator+(myPair(-a.first, -a.second));

}

a first;

b second;

};

class complex : myPair<int, int> {

public:

friend myPair;

complex(int real, int imaginary) : myPair(real, imaginary) {

 

}

int real() {

 return first;

}

int imaginary() {

 return second;

}

complex operator+(complex a) {

 return complex(myPair::operator+(a).first, myPair::operator+(a).second);

}

complex operator-(complex a) {

 return complex(myPair::operator-(a).first, myPair::operator-(a).second);

}

complex operator*(complex a) {

 return complex(real() * a.real(), imaginary() * a.imaginary());

}

};

int main() {

complex a(1, 2), b(10, 11);

cout << (a + b).real() << " " << (a + b).imaginary() << " " << (a - b).real() << " " << (a - b).imaginary() << " " << (a * b).real() << " " << (a * b).imaginary();

}

0,0(0 оценок)
Ответ:
Арина20071111
19.09.2021 20:54

n = int(input('Введите натуральное число:'))

count = 0

count_multiple = 0

numbers = []

while count_multiple < 1000 and n != 0:

   if n > 30000:

       print('Вы ввели число больше 30000! Попробуйте еще раз')

       n = int(input('Введите натуральное число:'))

       count_multiple += 1

   elif n % 5 == 0:

       numbers.append(n)

       n = int(input('Введите натуральное число:'))

       count_multiple += 1

       count += 1

   else:

       n = int(input('Введите натуральное число:'))

       count_multiple += 1

print(f'количество чисел кратных пяти = {count}')

Объяснение:

Python


11) напишите программу, которая в последовательности натуральных чисел определяет количество всех чё
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота