debchai123
08.01.2021 18:23

Вязыке c написать программу:
одномерные массивы. дана последовательность 10 целых чисел.
подсчитать сумму квадратов четных элементов.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Denair
20.12.2021 15:27

#include <iostream>

using namespace ::std;

int main()

{

   setlocale(LC_CTYPE , "rus");

   

   int n, i, j = 0, k = 0;

   double s = 0;

   cout << "Введите количество элементов: \n";

   cin >> n;

   float x;

   float *massiv = new float[n];

   if (!massiv)

   {

       cout << "Сбой программы!\n";

       system("pause");

        return 0;

   }

   cout << "Введите массив с " << ' ' << n << ' ' << "элементов\n";

   for (i = 0; i < n; i++)

       cin >> *(massiv + i);

   cout << "Заданный массив: " << endl;

   for (int i = 0; i < n; i++)

       

       cout << *(massiv + i) << ' ' << endl;

 

   for (i = 0; i<n; i++)

   {

       if (massiv[i]>0)

           k++;

   }

   cout << " Количество положительных элементов = " << k << '\n';

 

 

   for (i = 0; i<n; i++)

   {

       if (massiv[i] == 0) {

           j = massiv[i];

           x = i;

       }

   }

 

   for (i = x; i<n; i++)

       s += massiv[i];

 

   cout << "Сумма =" << s;

   float *massiv2 = new float[n];

   if (!massiv2)

   {

       cout << "Сбой программы !\n";

       system("pause");

       return 0;

   }

   for (i = 0; i < n; i++)

       if (massiv[i] <= 1)

       {

           massiv2[j] = massiv[i];

           j++;

       }

 

   for (i = 0; i < n; i++)

       if (fabs(massiv[i]) > 1)

       {

           massiv2[j] = massiv[i];

           j++;

       }

   cout << endl << "Отсортированный массив: " << endl;

   for (int j = 0; j < n; j++)

       cout << '\n' << massiv2[j] << ' ';

 

   delete[] massiv;

   delete[] massiv2;

   system("pause");

   return 0;

}

В работо не сомневайся.

0,0(0 оценок)
Ответ:
vovadj17
29.12.2020 21:51
Требуется перевести дробное десятичное число 206,116 в дробное двоичное число. 
Перевод целой части дает 206=11001110(для этого мы делим 206 на два и записываем остатки от деления) , затем дробную часть умножаем на основание 2, до тех пор, пока дробная часть не будет равна нулю, занося целые части произведения в разряды после запятой искомого дробного двоичного числа: 
.116 • 2 = 0.232 
.232 • 2 = 0.464 
.464 • 2 = 0.928 
.928 • 2 = 1.856 
.856 • 2 = 1.712 
.712 • 2 = 1.424 
.424 • 2 = 0.848 
.848 • 2 = 1.696 
.696 • 2 = 1.392 
.784 • 2 = 0.784 
Получим: 206=11001110,0001110110
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота