олтисьл
18.11.2020 03:50

100 + лучший ответ! написать программу на с:

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
AnfisaCat
10.10.2020 19:14

#include <stdio.h>

int main()  

{

FILE *f,*f1;

char c;

if((f=fopen("in.txt","r"))==NULL)

{

 printf("error");

 return 1;

}

f1=fopen("out.txt","w");

c=fgetc(f);

while(c!=EOF)

{

 fprintf(f1,"%c",c);

 c=fgetc(f);

}

fclose(f);

fclose(f1);

return 0;

}

0,0(0 оценок)
Ответ:
sonia81
10.10.2020 19:14

Объяснение:

#include<stdio.h>

int main(){int a,b;

FILE *f1;

FILE *f2;

char l;

f1=fopen("input.txt","r");

f2=fopen("output.txt","w");

if ( (!f1  ) ||   (!f2 )){printf("не удалось открыть один из файлов");return -1;}

while( (l=fgetc(f1)) !=EOF)

{  

  fprintf(f2,"%c",l);

   

}

fclose(f1);

fclose(f2);

return 0;

}


100 + лучший ответ! написать программу на с:
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота