Serebrennikova217
23.12.2022 06:51

Чай [python]

имя входного файла: tea.in или стандартный поток ввода
имя выходного файла: tea.out или стандартный поток вывода
ограничение времени: 1 с
ограничение памяти: 256m

петя любит и информатику, поэтому он решил начать готовиться к сразу по обоим предметам. для этого он составил расписание, которое выглядит так: сначала петя a дней готовится к по , затем b дней к по информатике, потом опять a дней готовится к по и т.д. также петя знает, что когда он занимается , он должен выпивать в день ровно c чашек чая, а в день занятий по информатике — d чашек.

решив начать готовиться с новой недели, петя захотел узнать, сколько ему нужно сделать запасов чая на n недель, которые остались до начала самых важных олимпиад. напишите программу, которая определяет сколько всего чашек чая выпьет петя за целое число недель n.

формат входных данных

в первой строке дается целое число
a (1≤a≤1000) — количество подряд идущих дней, которые петя тратит на подготовку к .

во второй строке дается целое число b (1≤b≤1000) — количество подряд идущих дней, которые петя тратит на подготовку к информатике.

в третьей строке дается целое число c (1≤c≤500) — количество чашек чая, которые будет в день пить петя во время подготовки к .

в четвертой строке дается целое число d (1≤d≤500) — количество чашек чая, которые будет в день пить петя во время подготовки к информатике.

в пятой строке дается целое число n (1≤n≤500) — количество недель подготовки пети.

формат результата
выведите одно число — сколько всего чашек чая выпьет петя за
n недель.

примеры

входные данные
3
4
1
1
1
результат работы
7

входные данные
1
2
3
4
2

результат работы
51

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kotenok88
16.02.2023 14:01

В питоне:

def start():

  print("Выберите")

  print("0 - См в М")

  print("1 - М в Мм")

  read = input()

  if (read == "0"):

     ooo()

  elif (read == "1"):

     aaa()

  else:

    print("Нет такого выбора")

    inf()

def ooo():

  print("Введите значение")

  cm = input()

  math = 100

  result = float(cm) / math

  print(result)

  start()

def aaa():

  print("Введите значение")

  m = input()

  math = 1000

  result = float(m) * math

  print(result)

  start()

def inf():

  read = input()

  if (read == "0"):

     ooo()

  elif (read == "1"):

     aaa()

  else:

    print("0 - См в М")

    print("1 - М в Мм")

    print("Нет такого выбора")

    inf()

start()

0,0(0 оценок)
Ответ:
SleepWalker5669
29.01.2022 21:14

Сохрани все самое важное и сделай сброс настроек

Выключи телефон. Если он заблокирован и не выключается, то зажми кнопки "Громкость -" и "Включение" на 8-9 секунд.

Затем одновременно зажми кнопки "Громкость +"  и "Включение"

Через 5 секунд отпусти кнопку "Включение". Кнопку "Громкость +" удерживай до появления рекавери меню (5-10 секунд)

Кнопками "Громокость +" и "Громкость -" выберите "wipe data/factory reset" и подтверди выбор кнопкой "Включение"

Затем выберите "Yes" и подтверди выбор кнопкой "Включение"

После выполнения сброса выбери "reboot system now"

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота