sashe123
09.12.2020 10:12

Написать программу в devc++ :
записать массивы а[n], которые имеют нечетные индексы и которые больше 10, переписать по порядку в массив b.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
жандос29
14.04.2022 05:53
Как-то так:

(+ на скрине результат работы)

#include <iostream>

using namespace std;

int main()

{

   int counter = 0;

   int size = 10;

   int* arr = new int[size]; // создание масива размера size

   for(int i = 0; i < size; i ++) // заполнение и вывод масива

   {

       arr[i] = i - 5;

       cout << arr[i] << " ";

   }

   cout << "\n\n";

   for(int i = 0; i < size; i ++)

   {

       if(arr[i] < 0 && arr[i] % 2 == 0)

       {  

           counter++;

           arr[i] = 665;

       }

       cout << arr[i] << " "; // вывод измененного масива

   }

   cout << "\nAmount = " << counter;  

   return 0;

}


ЯЗЫК C++ Підрахувати кількість парних від’ємних елементів масиву та присвоїти їм значення 665
0,0(0 оценок)
Ответ:
superM228228
17.04.2022 20:06

#include <iostream>

using namespace std;

int main()

{

   int N; cin >> N;

   int list[N];

   int a = 0;

   while (a < N)

   {

       int n; cin >> n;

       list[a] = n;

       a ++;

   }

   int flag_2 = 0;

   a = 0;

   while (a < N)

   {

       int b = 0;

       int flag = 0;

       while (b < N)

       {

           if (list[a] == list[b])

           {

               flag ++;

               flag_2 ++;

           }

           b ++;

       }

       if (flag > 1) cout << list[a] << " ";

       a ++;

   }

   if (flag_2 <= N) cout << 0;

}

1) ответ выводится не списком, а просто отдельными числами через пробел

2) каждое повторяющееся число выводится несколько раз(столько, сколько встречается)

3) в конце вывода лишний пробел

Могу решить на пайтоне, если важно просто закрыть задачу. А так, судя по всему, решение только массивами требует более глубоких знаний(динамические массивы и векторы), чем есть у меня в с++. Возможно, сможете улучшить мое решение

(кинул бы в комментарии, но там ограничение на кол-во символов)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота