pomxic
05.05.2021 17:07

Напишите программу в паскаль, сколько могу ​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
бооой
14.08.2022 00:47
Тексты вводятся в память компьютера с клавиатуры. На клавишах написаны привычные нам буквы, цифры, знаки препинания и другие символы. В оперативную память они попадают в двоичном коде. Это значит, что каждый символ представляется 8-разрядным двоичным кодом.

Кодирование заключается в том, что каждому символу ставится в соответствие уникальный десятичный код от 0 до 255 или соответствующий ему двоичный код от 00000000 до 11111111. Таким образом, человек различает символы по их начертанию, а компьютер - по их коду.

Удобство побайтового кодирования символов очевидно, поскольку байт - наименьшая адресуемая часть памяти и, следовательно, процессор может обратиться к каждому символу отдельно, выполняя обработку текста. С другой стороны, 256 символов – это вполне достаточное количество для представления самой разнообразной символьной информации.

Теперь возникает вопрос, какой именно восьмиразрядный двоичный код поставить в соответствие каждому символу.

Понятно, что это дело условное, можно придумать множество кодировки.

Все символы компьютерного алфавита пронумерованы от 0 до 255. Каждому номеру соответствует восьмиразрядный двоичный код от 00000000 до 11111111. Этот код просто порядковый номер символа в двоичной системе счисления.
0,0(0 оценок)
Ответ:
osolonskaya
14.03.2022 13:08
Program question;

var
   a: string;
   b: integer;

begin
     writeln('Сколько тебе лет?:');
     readln(b);
     if b > 17 then begin
                                 writeln('В каком институте ты учишься?:');
                                 readln(a);
                                 writeln(a, ' хороший институт');
                                 writeln('До следующей встречи!');
                            end
          else
     if b <= 17 then begin
                                 writeln('В какой школе ты учишься?');
                                 readln(a);
                                 writeln(a, ' не плохая школа');
                                 writeln('До следующей встречи!');
                                 end;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота