даринасид85
10.11.2021 02:38

Написать программу нахождения количества элементов, меньших 13 и кратных 8 массива а[8] заполненного случайными числами [-50,25)​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Happyunicorn28
10.10.2020 18:59

var a:array [1..10] of integer;

i,j:integer;

begin

 for i:=1 to 10 do a[i]:=random(-50,25);

 writeln ('Массив:');

 writeln (a);

 writeln ('Числа меньше 13 и кратные a[8]:');

 for i:=1 to 10 do

 if (a[i]<13) and (abs(a[i]) mod abs(a[8])=0 ) then write (a[i],' ');

end.

0,0(0 оценок)
Ответ:
123фидан321
10.10.2020 18:59

var i,k:integer;

a:array [1..8] of integer;

begin

write('Массив');

for i:=1 to 8 do

begin

a[i]:=random (75)-50;

write(a[i]:4);

if (a[i]<13) and (a[i] mod 8 = 0 ) then k:=k+1

end;

writeln;

writeln('Количество элементов, меньших 13 и кратных 8 равно ',k);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота