dollfasse
20.10.2020 22:06

На python выручайте нужно прямо , иначе пропал

время шло, а алиса всё продолжала падать. делать ей было совершенно нечего, и она снова стала рассуждать вслух:

— дина будет скучать без меня (дина — это алисина кошка). надеюсь, ей не забудут налить вечером в блюдечко молока… дина, моя милая, как было бы хорошо, если бы ты была сейчас со мной! правда, мыши здесь, наверное, только летучие, но ведь они похожи на обыкновенных. — алиса зевнула — ей вдруг захотелось спать, совсем сонным голосом проговорила:

— едят ли кошки летучих мышек? — она повторяла свой вопрос снова и снова, но иногда и спрашивала:

— едят ли летучие мышки кошек?

— впрочем, если некому ответить, то не всё ли равно, о чём спрашивать, верно?

вообще-то дина разборчивая кошка. и летучих мышек она не ест, она с ними знакомится. но их много, со всеми не перезнакомишься. нужно как-то выбирать, например, представляться только мышке с номером, начинающимся с загаданной цифры.

напишите программу, которая выводит все числа последовательности, начинающиеся заданной цифрой k.

если некоторое число появлялось в последовательности более одного раза, то нужно вывести его только один раз.

порядок вывода значения не имеет.

формат ввода

в первой строке вам дается произвольная цифра k.

во второй строке дается последовательность из нескольких натуральных чисел, записанных через пробел.

формат вывода

несколько чисел записанных через пробел.

пример 1

ввод вывод

2

2 12 212 1212 21212

2 21212 212

пример 2

ввод вывод

3

1 4 7 10 13 16 19 22 25 28 31 34 37

37 34 31

пример 3

ввод вывод

2

2 12 22 12 2

22 2

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Mehriban2007
02.03.2023 02:33
#include <iostream>
#include <windows.h>

void main()
{
    byte mass2_1[50];
    byte * mass_pointer = mass2_1;
    uint sum = 0;
    while(*(mass_pointer) && *(mass_pointer++) = rand()%15+5)
    {
        sum += *(mass_pointer - 1);
        std::cout << "[" << *(mass_pointer - 1) << "]";
    }
    std::cout << std::endl << "Summary: " << sum << std::endl;
    system("pause >nul");  
}

Доброго времени суток! Вы не указали язык? Держите ответ на С++ да еще и вне формата! :D
0,0(0 оценок)
Ответ:
asalymbekov
15.08.2022 04:54
1100001^2
1100001^2=1*2^7+1*2^6+0+0+0+0+1*2^0=128+64+1=193^10
ответ:193
Пояснение:для того чтобы перевести двоичную в десятичную-надо сначала посчитать количество разрядов числа с конца начиная с 0-то есть число будет выглядеть так 0 1 2 3 4 5 6 7- 7 разрядов,потом берём первое число 1 умножаем его на 2 в степени семь,так как последний разряд и степень 7,получиться число 128=2^7,прибавляем к этому следующее число степень которого 6,то есть 2^6=64,дальше всё 0 и прибавляем к этому последний разряд 2^0=1,следовательно и получается 128+64+1=193

 
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота