yulokkons
19.04.2022 04:31

: необходимо написать программу, которая вычисляет значение функции значение x вводится с клавиатуры.

\(y (x) = {tg (3x)^{x-5} - 4.5 \over 3}\)

примечание:

х принадлежит множеству рациональных чисел
вывод дробных чисел осуществлять с двумя знаками после запятой
подсказка. для округления чисел в с++ присутствуют различные встроенные функции. одна из них проанализируйте следующий код. возможно он будет полезен:

cout < < round(value*10)/10 < < endl; // округление до первого знака
cout < < round(value*100)/100 < < endl; // второго
cout < < round(value*1000)/1000 < < endl; // третьего
cout < < round(value*1)/1 < < endl; // четвертого
входной сигнал образца:

1
выход образца:

-1.5

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
creativeIgorek
21.12.2022 08:02
Var
A,B,C:integer;
Begin

WriteLn('Введите три числа');
ReadLn(A,B,C);
if (A<=B)and(B<=C) then Write(A,' ',B,' ',C)
else if (A<=C)and(C<=B) then Write(A,' ',C,' ',B)
else if (B<=A)and(A<=C) then Write(B,' ',A,' ',C)
else if (B<=C)and(C<=A) then Write(B,' ',C,' ',A)
else if (C<=A)and(A<=B) then Write(C,' ',A,' ',B)
else if (C<=B)and(B<=A) then Write(C,' ',B,' ',A)
End.

Var a,b,c,D:real;
Begin
Write('a = ');ReadLn(a);
Write('b = ');ReadLn(b);
Write('c = ');ReadLn(c);
D:=b*b-4*a*c;
if D>=0 then
   Begin
   WriteLn('x = ',(-b-sqrt(D))/(2*a));
   WriteLn('x = ',(-b+sqrt(D))/(2*a));
   End
else WriteLn('Действительных корней нет')
End.
0,0(0 оценок)
Ответ:
Ксюшка221
21.12.2022 08:02
var a,b,c,d,x,x1,x2:real;
begin
  write ('a='); read (a);
  write ('b='); read (b);
  write ('c='); read (c);
  d:=b*b-4*a*c;
  if d<0 then writeln ('NO')
         else if d>0 then
                       begin
                         x1:=(-b+sqrt(d))/(2*a);
                         x2:=(-b-sqrt(d))/(2*a);
                         writeln ('x1=',x1:0:2,' x2=',x2:0:2)
                       end
                     else
                       begin
                         x:=-b/(2*a);
                         writeln ('x=',x);
                       end
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота