СделаноВРоссии
06.09.2020 17:24

хотя бы одно из
1.написать программу вычисления суммы четных элементов массива,состоящего из 10 чисел,заполненных случайным образом от10 до30. 2.написать программу ,которая находит произведение элементов массива , состоящего из 10 чисел, заполненого по формуле a[i]=i*i-10

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
StepaBeng
26.09.2021 00:00
Вообще надо думать своей головой ты же учишься в ШП)Hо если ты хочешь тупо все списывать и тебя заставляют их выполнять держи, мне не жалко:a = input()

d = len(a)

print(a[0:1].upper() + a[1:d].lower())

Объяснение(Если ты это и вправду читаешь, то тебе уже интересно, как это работает, это уже хорошо):

Запрашиваем переменную a

Переменная d = сколько в переменной a символов

выводим(от переменной a первый символ капсом + присоединяем остальное слово мал.буквами

Все элементарно и понятно! Учись, кхм.. То есть списывай на здоровье!

0,0(0 оценок)
Ответ:
popova2015
19.11.2020 10:10
Программа на python 3, перебирающая все возможные последовательности определённой длины:
def shortest_chains(n):
  def next_chains(chain):
    new_elems = set()
    for i in range(len(chain)):
      for j in range(i, len(chain)):
        new_elem = chain[i] + chain[j]
        if new_elem > chain[-1] and new_elem not in new_elems:
          new_elems.add(new_elem)
          yield chain + [new_elem]
  
  current_stage = None
  next_stage = [[1]]
  answer = []
  while len(answer) == 0:
    current_stage = next_stage
    next_stage = []
    for chain in current_stage:
      next_stage.extend(next_chains(chain))
    answer = [chain[1:] for chain in next_stage if chain[-1] == n]
  return answer
    
def print_solution(n):
  answer = shortest_chains(n)
  print("Для {} есть {} решений(-я, -е):".format(n, len(answer)))
  for i in range(len(answer)):
    print("{}. {}".format(i + 1, " ".join(map(str, answer[i]
  print()

Запустив, можно получить все 5 возможных решений для числа 7, по 4 решения для 15 и 23 и 87 решений для 63.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота