olesazato
08.03.2021 16:27

Тест
b19 - обработка массивов
в программе используется одномерный целочисленный массив ас индексами от 0 де
9. значения элементов равны 1, 5, 3, 7, 9, 8, 1, 12, 6, 14
соответственно, т.е. a [0] =1, a[ 1] =5ит.д. определите значение переменной ѕ
после выполнения следующего фрагмента этой программы:
s : = 0;
n: = 10;
for i: =1 to n-2 do begin
s : = s + a[i] - a[i+1];
end;
вредите правильный ответ​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
apzjxmskaposjxhdh
01.02.2020 08:03
Второе красиво решил через строки MinGW GCC 4.7.1
#include <iostream>
#include <string>
#include <locale.h>
using namespace std;
char max(char a, char b)
{
return (a > b) ? a : b;
}
char min(char a, char b)
{
return (a < b) ? a : b;
}
int main(void)
{
setlocale(LC_ALL,"rus");
string s;
cout<<"Введите число: "; cin>>s;
char min_c = '9', max_c = '0';
for(size_t i = 0; i < s.length(); i++)
{
max_c = max(s[i], max_c);
min_c = min(s[i], min_c);
}
cout << "Наибольшая цифра: " << max_c << endl <<"Наименьшая цифра: " << min_c << endl;
return 0;
}
0,0(0 оценок)
Ответ:
ARMY130613
08.04.2022 09:34
А) не ( A или не В и С ) упрощаем выражение и получаем
not(a) and (b or not(c))

Код на Python:

for a in range(0,2):
    for b in range(0,2):
        for c in range(0,2):
            f=not(a) and (b or not(c))
            print('A = ',a,'B = ',b,'C = ',c,'F = ',f)

б) А и не ( В и или не С) получим такое выражение:
a and (b or not(c))

Код на Python:

for a in range(0,2):
    for b in range(0,2):
        for c in range(0,2):
            f=a and (b or not(c))
            print('A = ',a,'B = ',b,'C = ',c,'F = ',f)


в) не ( не А или В и С)  преобразуем:
a and (b or c)

Код на Python:

for a in range(0,2):
    for b in range(0,2):
        for c in range(0,2):
            f=a and (b or c)
            print('A = ',a,'B = ',b,'C = ',c,'F = ',f)
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота