kamilakruvetka
17.03.2022 03:43

Целочисленный массив 30 элементов элементы массива могут принимать целые значе минус 300 до 300 включительно написать программу содержащие фото значения элементов массива с клавиатуры и вывод на экран в строку

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kostya2031
15.11.2020 07:25
Const
  nn=50;

type
  data = record
    number : 1..31;
    month : 1..12;
    year : 1901..1997
  end;

var
  d:array[1..nn] of data;
  i,n,k:integer;
  s,s1,s2,s3:string;
begin
  Write('Количество дат (1..50)-> '); Read(n);
  Writeln('Введите через пробел день, месяц, год: ');
  for i:=1 to n do Read(d[i].number,d[i].month,d[i].year);
  { a }
  Write('Самый ранний из годов: ');
  k:=d[1].year;
  for i:=2 to n do
    if d[i].year<k then k:=d[i].year;
  Writeln(k);
  { б }
  Writeln('Все весенние даты');
  for i:=1 to n do
    if d[i].month in [3..5] then
      Write(d[i].number,'.',d[i].month,'.',d[i].year,' ');
  Writeln;
  { в }
  Write('Cамая поздняя дата: ');
  Str(d[1].year,s1); Str(d[1].month,s2); Str(d[1].number,s3);
  if Length(s2)=1 then s2:='0'+s2;
  if Length(s3)=1 then s3:='0'+s3;
  s:=s1+s2+s3;
  for i:=2 to n do
  begin
    Str(d[i].year,s1); Str(d[i].month,s2); Str(d[i].number,s3);
    if Length(s2)=1 then s2:='0'+s2;
    if Length(s3)=1 then s3:='0'+s3;
    if s<s1+s2+s3 then s:=s1+s2+s3
  end;
  Writeln(Copy(s,7,2)+'.'+Copy(s,5,2)+'.'+Copy(s,1,4))
end.

Тестовое решение:
Количество дат (1..50)-> 6
Введите через пробел день, месяц, год:
18 4 1950
16 5 1968
5 8 1970
3 9 1968
11 6 1964
16 12 1967
Самый ранний из годов: 1950
Все весенние даты
18.4.1950 16.5.1968
Cамая поздняя дата: 05.08.1970
0,0(0 оценок)
Ответ:
matlis
18.01.2021 00:55
Первая программа может выглядеть так:

uses crt;
const n=10;
type Mas=array [1..n] of integer;
Var A: Mas;
  i, x:integer;
  priznak: boolean;

Begin
 ClrScr;
 priznak:=false;
 WriteLn(' Massiv: ');
 for i:=1 to n do
     begin
       A[i]:=-100+random(200);
       Write(A[i]:5);
     end;
 WriteLn;
 Write(' X = '); ReadLn(X);
 WriteLn;
  for i:=1 to n do
        if X=A[i] then
        begin
        WriteLn (' X = ', A[i], '     Index = ', i);
        priznak:=true;
       end;
 if priznak=false then Writeln (' None...');

 ReadLn;
end.

2. А вот реверс:

uses crt;
const n=10;
type Mas=array [1..n] of integer;
Var A: Mas;
  i:integer;
 
Begin
 ClrScr;
  WriteLn(' Massiv: ');
 for i:=1 to n do
     begin
       A[i]:=-100+random(201);
       Write(A[i]:5);
     end;
 WriteLn;
  WriteLn(' Revers: ');
 for i:=n downto 1 do
       Write(A[i]:5);
 WriteLn;
 ReadLn;
end.

И. наконец, последняя программа:

uses crt;
const n=5;
 var i, x : integer;
     P:longint;

begin
 ClrScr;
 P:=1;
 WriteLn(' Wwod Massiva: ');
 for i:=1 to n do
     begin
       ReadLn (x);
       P:=P*x;
     end;
 WriteLn;
 WriteLn(' P = ', P);
 WriteLn;
 ReadLn;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота