Кндр15
09.08.2020 01:18

Напишите программу на python которая считает сколько цифр окончиваетсч на 2; такуюде но для чисел оканчивающинся на 4 и для чисел оканчивающинся на 7!
так же напишите программу которая считает минимум среди двузначних, либо среди первых 5 чисел! 100 ! ​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
66vdv1
10.10.2020 17:35

1)

print("Введите числа через пробел")

list1 = input().split()

counter = 0

for elem in list1:

   if(elem[-1]=='2'):

       counter += 1

print(counter)

2)

print("Введите числа через пробел")

list1 = input().split()

counter = 0

for elem in list1:

   if(elem[-1]=='4'):

       counter += 1

print(counter)

3)

print("Введите числа через пробел")

list1 = input().split()

counter = 0

for elem in list1:

   if(elem[-1]=='7'):

       counter += 1

print(counter)

4)

list1 = input().split()

counter = 0

list2 = []

key = False

for i in list1:

   if(len(i) >= 2):

       key = True

       list2.append(i)

list1 = [int(i) for i in list1]

if not(key):

   print(min(list1[0:4]))

else:

   print(min(list2))

То же самое в pastebin:

https://pastebin.com/byZKnUaF

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота