DarvinaDark
22.03.2021 10:13

Вариант 7. составьте программу – временной интервал. заданы моменты начала и конца некоторого промежутка времени в часах и минутах (в пределах одних суток). найти продолжительность этого промежутка в тех же единицах измерения.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
pidortema
14.02.2021 10:28
1. Для цикла For есть решение выложенное выше  от Srzontmp.

2. Почти ничего не меня получим код для цикла while:
var
  i, n, k: integer;
begin
  i := 2;
  readln(n);
  while i <= n div 2 do begin
    if (n mod i) = 0 then k := i;
    i:=i+1;
    end;
  writeln('наибольший делитель ', n, ' = ', k);
end.

3. Аналогично для цикла Repeat:
var
  i, n, k: integer;
begin
  i := 2;
  readln(n);
  repeat
    if (n mod i) = 0 then k := i;
    i:=i+1;
  until i> n div 2;
  writeln('наибольший делитель ', n, ' = ', k);
end.
0,0(0 оценок)
Ответ:
крымнаш
05.02.2020 09:57

Серверы файловых архивов в операционной системе Windows.:

В Интернете существуют серверы файловых архивов, на которых хранятся файлы различных типов (программы, драйверы устройств, графические и звуковые файлы и т. д.). Наличие таких серверов файловых архивов очень удобно для пользователей, так как многие необходимые файлы можно скачать непосредственно из Интернета.

Серверы файловых архивов, а также возможность скачать программу поддерживают многие компании — разработчики программного обеспечения и производители аппаратных компонентов компьютера и периферийных устройств. Размещаемое на таких серверах программное обеспечение является свободно рас или условно бесплатным, и поэтому, скачивая тот или иной файл, пользователь не нарушает закон об авторских правах на программное обеспечение.

Менеджеры загрузки файлов. В операционной системе  Windows для удобства пользователей многие серверы файловых архивов (freeware.ru, www.freesoft.ru,www.download.ru) имеют Web-интерфейс, что позволяет работать с ними с использованием браузеров. Браузеры являются интегрированными системами для работы с различными информационными ресурсами Интернета и поэтому включают в себя менеджеры загрузки файлов.

Однако для работы с файловыми архивами удобнее использовать специализированные менеджеры загрузки файлов, которые позволяют приостановить загрузку файла после разрыва соединения с сервером, а затем возобновить загрузку с последнего места её прерывания после восстановления связи с Интернетом. В некоторых менеджерах загрузки файлов (например, FlashGet) достигается увеличение скорости загрузки за счет разбиения файла на части и одновременной загрузки всех частей.

Менеджеры загрузки файлов предоставляют пользователю подробную информацию в числовом и графическом виде о процессе загрузки файла (объем файла, объем загруженной части, в том числе в процентах, скорость загрузки и оставшееся время загрузки и др.).

Адрес файла на сервере файлового архива. Доступ к файлам на серверах файловых архивов возможен как по протоколу HTTP, так и по специальному протоколу передачи файлов FTP (File Transfer Protocol). Протокол FTP позволяет не только загружать файлы с удаленных серверов файловых архивов на локальный компьютер, но и, наоборот, производить передачу файлов с локального компьютера на удаленный сервер.

Адрес файла на сервере файлового архива включает в себя доступа к файлу, имя сервера Интернета, на котором находится файл, и имя файла.

Если в качестве доступа к файлу file.exe, хранящемуся на сервере ftp.microsoft.com/, используется протокол передачи файлов FTP, то адрес файла запишется следующим образом:

ftp://ftp.microsoft.com/file.exe

Репозитарии программ в операционной системе Linux. В операционной системе Linux компоненты самой системы и приложения хранятся в репозитариях в виде «пакетов» (расширение rpm), которые каждый пользователь может скачать и установить в своем варианте системы. То есть каждый пользователь компонует свою операционную систему  Linux и ее приложения исходя из своих нужд и предпочтений, используя для этого набор пакетов в репозитариях.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота