Aqvtttt
05.07.2021 02:48

Написать программу для проверки попадания точки с производными координатами x,y в область плоскости , показанную штриховкой на рисунке. случай попадания на границу области выделяется особо. координаты точки вводятся в ручную

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
АртурЗезарахов
13.07.2020 09:27

1.var

N,a,b:integer;

 begin    

 a:=N;

b:=N-8;

     readln(a);

   write(a);

       write(b);

 end.

2.var

S,P, a,b:integer;

 begin

   read(a);

   read (b);

   begin

   P:=(a+b)*2;

  write('Периметр:',P); end;

  begin

  S:=a*b;  write('Площадь:',S); end;

 end.

3.

var

a,b,c:string;

 begin

    write('Как вас зовут?');

   readln(a);

   write('Сколько вам лет?');

   readln (b);

    write('Какой у вас номер телефона?');

      readln (c);

 

       write('Имя:',a);

  write('Возраст:',b);

   write('Номер телефона:',c);

 end.

0,0(0 оценок)
Ответ:
Paris99
02.02.2023 14:37

Когда после ключевых слов then или else вновь используются условные операторы, они называются вложенными. Число вложений может быть произвольно, при этом действует правило: else всегда относится к ближайшему оператору if , для которого ветка else еще не указана. Часто вложением условных операторов можно заменить использование составного.

В качестве примера рассмотрим программу для определения номера координатной четверти p, в которой находится точка с координатами (x,y). Для простоты примем, что точка не лежит на осях координат. Без использования вложений основная часть программы может иметь следующий вид:

if (x>0) and (y>0) then p:=1

else if (x<0) and (y>0) then p:=2

else if (x<0) and (y<0) then p:=3

else p:=4;

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота