Написать программу подсчета суммы элемента массива, с выводом и в строку

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ilias1924
20.01.2022 23:00
// PascalABC.NET 3.2, сборка 1383 от 09.02.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('Количество строк в массиве:');
  var m:=ReadInteger('Количество столбцов в массиве:');
  Writeln('*** Исходный массив [',n,',',m,'] ***');
  var a:=MatrRandom(n,m,-99,99);
  a.Println(5); Writeln(5*a.ColCount*'-');
  Writeln('Сумма элементов массива: ',
      a.Rows.SelectMany(x->x).Sum)
end.

Пример
Количество строк в массиве: 6
Количество столбцов в массиве: 9
*** Исходный массив [6,9] ***
   39   99   51   44  -28  -85  -52  -98  -56
   68   41    3   34   54  -39  -72   15  -80
   47  -11   35  -50   65   70   58   52   -1
   38   82  -37   93   32   51  -82  -32   98
  -72  -12   59   87   44   -4  -14  -56   13
   44   72    1   63   48  -77    4  -28   73

Сумма элементов массива: 691
0,0(0 оценок)
Ответ:
zaynab20032003
29.08.2020 09:56
Блок-схема - в прилагаемом файле.
var n:integer; a,b,r,x,y,z,p,s:real;
begin
writeln('Введите номер фигуры: 1) прямоугольник; 2) круг; 3) треугольник:');
readln(n);
case n of
 1: begin 
    write('a, b: '); readln(a,b);
    s:=a*b;
    writeln('s = ',s);
    end;
 2: begin 
    write('r = '); readln(r);
    s:=pi*r*r;
    writeln('s = ',s);
    end;
 3: begin 
    write('x, y, z: '); readln(x,y,z);
    p:=(x+y+z)/2;    s:=sqrt(p*(p-x)*(p-y)*(p-z));    writeln('s = ',s);
    end;
 else writeln('Ошибка ввода');
 end;
end.

Пример:
Введите номер фигуры: 1) прямоугольник; 2) круг; 3) треугольник:
3
x, y, z: 3 4 5
s = 6
Даны три фигуры: 1 ) прямоугольник со сторонами a = 2, b = 3 2 ) круг радиуса r = 5 3 ) треугольник
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота