Elnur19982
16.03.2023 06:40

Напишите программу на языке паскаль

дан периметр прямоугольника и сторона а. определите площадь прямоугольника

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
5628462847
17.06.2020 00:13
// PascalABC.NET 3.3, сборка 1561 от 02.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln('Введите в строку элементы массива A[3x3]');
  var A:=ReadMatrReal(3,3);
  Writeln('Введите в строку элементы массива B[3x3]');
  var B:=ReadMatrReal(3,3);
  var C:=new real[3,3];
  for var i:=0 to C.RowCount-1 do
    for var j:=0 to C.ColCount-1 do
      C[i,j]:=A[i,j]/B[i,j];
  Writeln('*** Массив С ***');
  C.Println(10,5)
end.

Пример
Введите в строку элементы массива A[3x3]
3 5 -2 1.5 0.7 6 -0.5 4 2.2
Введите в строку элементы массива B[3x3]
0.6 5 3 7.4 -7.13 9.1 -2 0.8 6.42
*** Массив С ***
   5.00000   1.00000  -0.66667
   0.20270  -0.09818   0.65934
   0.25000   5.00000   0.34268
0,0(0 оценок)
Ответ:
Radjabaliev
02.05.2022 08:26
#include <cstdlib>
#include <cmath> //подключаем библеотеку с функцией pow
#include <iostream>//имеющиеся модули

using namespace std;//пространство имен

int main() {
int a, b;// ввод переменных
cin >> a >> b;// ввод на клавиатуре a = pow(a, 2);//возводим a в степень 2
printf("a=%d ", a);//выводим новые значения a 
if (b < 0) {
printf("не возможно подсчитать "); //проверка (подкоренное выражение не отрицательно)

} else {
b = pow(b, 0.5);//возводим b в степень 0.5(корень квадратный)
printf("b=%d ", b);//выводим новые значения b
}
system("pause");//ставит программу на паузу
return 0;// говорит системе что все закончилось успешно
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота