1) Какое число будет выведено на экран после выполнения этого фрагмента программы?
write(1);
for i:=2 to 3 do цикл будет работать ровно 2 раза
write(i); тут получается с начала выведется число 2 потом 3
ответ 3
2) Чему будет равно значение целой переменной «a» после выполнения этого фрагмента программы?
a:=2;
for i:=0 to 2 do Цикл будет работать 3 раза
begin
a:=a+i 2+0=2 2+1=3 3+2=5
end;
ответ 5
3) Чему будет равно значение целой переменной «a» после выполнения этого фрагмента программы?
a:=10;
for i:=1 to 3 do Цикл будет работать 3 раза
begin
a:=a-1 10-1=9 9-2=7 7-3=4
end;
ответ 4
Объяснение:
PascalABC.NET 3.5.1
begin
var a := ReadString().ToCharArray.ToList; //Читаем с консоли число как строку, разбиваем на массив символов и приводим к типу List<T> для удобства работы
var fnum := a[0]; //Запишем в переменную fnum первый элемент получившегося списка цифр нашего числа (то бишь первую слева цифру)
a.Remove(fnum); //Удалим из этого списка эту цифру
a.AddRange(Seq(fnum, fnum)); //Добавим в конец нашего списка цифр эту самую последнюю цифру два раза
a.JoinIntoString.Println; //Соберём элементы нашего списка в строку и выведем на печать
end.
Объяснение: