Oishahon
18.02.2021 03:15

Составить программу на паскале для обработки массива z=(2.13; 14.1; −13.66; 0; −2; −16.5; 12; 142.3; 122; 111) при b = 3. посчитать количество и напечатать номера элементов, которые больше b, с нечетными номерами. (30 )
составить программу на паскале для обработки двумерного массива размерностью 3*4. массив заполнить самостоятельно. вычислить сумму положительных элементов каждой строки двумерного массива. (30 )
составить программу на паскале, которая удалит все пробелы из текста. текст: «информатика − наука, изучающая структуру, общие свойства и методы передачи информации». (40 )
на проверку нужно прислать коды программ и результаты работы.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
manechka2407
03.09.2020 04:03

Человеческое общество по мере своего развития овладевало не только веществом и энергией, но и информацией. С появлением и массовым рас компьютеров человек получил мощное средство для эффективного использования информационных ресурсов, для усиления своей интеллектуальной деятельности. С этого момента (середина XX века) начался переход от индустриального общества к обществу информационному, в котором главным ресурсом становится информация.

Возможность использования членами общества полной, своевременной и достоверной информации в значительной мере зависит от степени развития и освоения новых информационных технологий, основой которых являются компьютеры. Рассмотрим основные вехи в истории их развития.

Объяснение:

Нужно использовать декодер. Например этот:

https://www.artlebedev.ru/decoder/

0,0(0 оценок)
Ответ:
verarusu02
06.05.2023 07:22
// PascalABC.NET 3.0, сборка 1157 от 02.02.2016
begin
  var a:array[1..20] of integer;
  Randomize;
  for var i:=1 to 20 do a[i]:=Random(-50,50); a.Println;
  var b:=Range(2,20,2).Select(i->a[i]);
  Writeln('Элементы с четными индексами по возрастанию');
  b.Sorted.Println;
  Writeln('Элементы с четными индексами по убыванию');
  b.SortedDescending.Println;
end.

Тестовое решение:
-15 46 -34 -3 43 16 -17 -28 -19 12 -28 -11 48 -12 -1 33 -37 9 6 -40
Элементы с четными индексами по возрастанию
-40 -28 -12 -11 -3 9 12 16 33 46
Элементы с четными индексами по убыванию
46 33 16 12 9 -3 -11 -12 -28 -40
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота