syrlybai056
15.03.2020 18:16

Написать программу на паскале

при вводе x и y образуется точка, нужно чтобы это точка при нахождении в закрашенной области писало "точка находится в закрашенной области" , "точка находится на границе закрашенной области" и "точка вне закрашенной области" при этом нужно проверить все вариации

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
fedorovufa
24.12.2022 09:24

type

 Str = record

         fio: string;

         h: byte;

       end;

var

 base: array of Str;

 i,sum,n,err:integer;

 

begin

write('Число учеников: '); readln(n);

setlength(base,n);

sum:=0;

writeln('Введите фамилию и рост через "space": ');

for i:=0 to n-1 do

 begin

   write(i+1:4,'. ');

   readln(base[i].fio);

   

   val(copy(base[i].fio,

            pos(' ',base[i].fio)+1,  

            length(base[i].fio)-pos(' ',base[i].fio)),

       base[i].h,  

       err);

   delete(base[i].fio,

          pos(' ',base[i].fio),

          length(base[i].fio));

   sum:=sum+base[i].h;

 end;

writeln('Средний рост: ',sum/n:4:1);

for i:=0 to n-1 do

 if base[i].h<sum/n then

   writeln(base[i]);

end.

0,0(0 оценок)
Ответ:
Igor20018
29.09.2020 23:03

Он создан как продолжение идей языка Лого и конструктора Лего. Скретч 1.4 был написан на языке Squeak, 2.0 и 3.0 ориентированы на работу онлайн. Scratch 2.0 был переписан на Flash и ActionScript. Скретч 3.0 (текущая версия) является улучшенной версией Скретч 2.0 и сделана на HTML5, используя движок WebGL, что даёт ему возможность работать на мобильных устройствах и планшетах. Скретч разрабатывается небольшой командой программистов для детей[3] в Массачусетском технологическом институте. Текущая версия — Скретч 3.0, выпущена в январе 2019 года. В 2008 году Скретч был портирован для микроконтроллерного модуля Arduino. Проект носит название S4A[4].

Программы на Скретче состоят из графических блоков, подписи к которым зависят от выбранного для интерфейса языка. Может быть выбран один из 50 языков интерфейса, включая русский. Для подключения интерфейса на новом языке используются стандартные gettext-файлы

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота