ВАС12237
06.11.2021 07:14

Знатокам питона
нужно написать программу:
надо задать вопросы пользователю."задумай число", "умножь его на два", "добавь пять", ""умножь еще раз на два"
после каждого вопроса поставьте задержку и продолжите в случае нажимания enter функция input
дать возможность пользователю ответить на вопрос "сколько ты получил? "
вывести на экран число которое задумал пользователь в таком виде: "ты задумал число " вместо прочерка должно вывестись задуманное число
используй формулу для нахождения числа:
задуманное число = (полученное число /2-5)/2

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
yanaberseneva
18.06.2021 05:41

Объяснение:

var

a, b, S, c, alpha, betta, gamma, H, P: real;

x, ar, br, gr: real;{alpha, beta. gamma в радианах}

begin

write('Введите длины двух сторон треугольника и площадь: ');

readln(a, b, S);

x := 2 * S / (a * b);

if x > 1 then writeln('Такой треугольник невозможен')

else

begin

gr := ArcSin(x);

c := Sqrt(Sqr(a) + Sqr(b) - 2 * a * b * Cos(gr));

P := a + b + c;

ar := ArcSin(a * Sin(gr) / c);

br := Pi - (ar + gr);

H := b * Sin(ar);

alpha := ar * 180 / Pi;

betta := br * 180 / Pi;

gamma := 180 - (alpha + betta);

writeln('Решение треугольника');

writeln('a=', a, ', b=', b, ', c=', c:0:5);

writeln('Alpha=', alpha:0:2, ', Betta=', betta:0:2, ', Gamma=', gamma:0:2);

writeln('P=', P:0:5, ', H=', H:0:5, ', S=', S)

end

end.

Тестовое решение:

Введите длины двух сторон треугольника и площадь: 3 4 6

Решение треугольника

a=3, b=4, c=5.00000

Alpha=36.87, Betta=53.13, Gamma=90.00

P=12.00000, H=2.40000, S=6

0,0(0 оценок)
Ответ:
Быковских
26.04.2021 17:45

#include <iostream>

#include <vector>

using namespace std;

int main()

{

   int s = 0, l = 1, n;

   cin >> n;

   vector <int> v(n);

   for (int i = 0; i < n; ++i)

   {

       cin >> v[i];

       if (v[i] > 0)

       {

           s += v[i];

       }

   }

   int imn = 0, imx = 0;

   for (int i = 0; i < n; ++i)

   {

       if (v[i] < v[imn])

       {

           imn = i;

       }

       if (v[i] > v[imx])

       {

           imx = i;

       }

   }

   if (imn > imx)

       {

           swap (v[imn], v[imx]);

       }

   for (int i = imn; i < imx; i++)

   {

       if (v[i] > 0)

       {

           l *= v[i];

       }

   }

   cout << s << " " << l;

   return 0;

}

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота