Войти
Регистрация
Спроси ai-bota
gek45
20.03.2021 13:04
Кумир.
составьте программу, которая находит количество нулей в целом десятичном числе, введенном с экрана. результат выводится на экран.
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Anastasia934
20.11.2020 14:42
Выберите наиболее удачное имя для файла с письмом другу -документ 5 - - письмо -письмо_пете...
vlad31106
20.11.2020 14:42
Символ «: =» обозначает оператор присваивания, знаки «+», «–», «*» и «/» – соответственно операции сложения, вычитания, умножения и деления. правила выполнения операций...
MyNameIsLiza123
03.09.2022 19:11
Даны три числа: А= 100102, В= 1710, С= 2210. Переведите числа в двоичную систему счисления и выполните поразрядно логические операции ¬AvB^C. ответ дайте в десятичной...
Sergant17
21.12.2020 03:16
Презентация на тему виды роботов очень...
элллллляяяяя555
13.04.2022 16:48
Изучи предложенное изображение и определи ошибку в программном коде.3В - Стах уАА10-500- 301Верных ответов: 2определение яркости отраженногоСветадвижение назад на один...
cstlm
12.10.2022 07:45
26.01 2021/esson/a0bdec84 cdb9-4383-ala-bb651b0baded Повороты. Урок 1Сравни предложенные варианты использования блока «Независимое управление» и выбери тот, прикотором...
даша3474
23.09.2020 16:06
Создайте семантическую модель связей в предложении: Белет парус одинокий в тумане моря голубом ....
gavronovaanna2oz9c0h
13.01.2021 11:26
2. Лиза купила в магазине n пар обуви по 1500 рублей и f платьев за 2300. Сколько всего потратила Лиза на покупки? Составьте алгоритм в виде блок-схемы. 4. Одна компания...
Bigdaddypro100
18.06.2020 01:41
Значение слова регалия,тщеславия, позёртство. И составить с этими словами словосочетание. ...
Andreyко
18.06.2020 01:41
ть з хімієюЯ не розумію її...
Ответ:
bezrodnayamila
06.04.2023 06:48
// PascalABC.NET 3.0, сборка 1144 от 16.01.2016
begin
var a:=ArrRandom(100,-10,10);
a.Println;
Writeln(a.Where(x->x>0).Count,' положительных, ',
a.Where(x->x<0).Count,' отрицательных')
end.
Тестовое решение:
4 -6 0 8 2 -2 -1 -8 -6 8 -3 7 4 -7 -5 9 0 -3 -7 1 0 -4 6 3 8 -10 4 9 3 5 8 5 5 8 10 4 -8 3 8 8 -9 2 7 -8 -7 -5 2 -9 0 9 -7 7 -2 -6 7 -2 -1 7 -10 2 4 1 -1 0 10 3 -8 6 -6 2 6 7 -1 -4 -1 8 0 3 0 2 -2 2 -1 5 1 -9 -4 1 -9 1 -6 -5 3 -4 -7 1 -7 -3 -7 1
51 положительных, 42 отрицательных
0,0
(0 оценок)
Ответ:
rami1991
06.04.2023 06:48
// PascalABC.NET 3.3, сборка 1611 от 06.01.2018
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(100,-20,20); a.Println;
Writeln('Положительных ',a.Where(t->t>0).Count,
', отрицательных ',a.Where(t->t<0).Count)
end.
Пример
19 7 4 15 15 -16 20 6 1 7 -15 -13 3 0 -10 -17 -14 -16 12 -9 -16 -6 6 10 4 -17 -17 19 20 -12 -18 18 9 -14 -17 -11 6 4 -8 -20 -2 18 -3 -6 -6 -12 -8 -8 -11 13 -6 19 19 3 -14 4 -19 14 -10 11 -19 -19 6 -8 4 -13 -2 -4 -3 -19 -2 3 12 11 14 -13 18 -9 -4 -4 12 11 9 -14 14 -17 20 -15 20 -1 -12 13 -7 1 20 -4 -9 -16 10 -13
Положительных 45, отрицательных 54
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота