ilyawifiilyap00qfm
27.05.2022 23:36

Напишите программу которая заменяет во всей строке одну последовательность символов на другую.
пример:
введите строку:
(x> 0) and (yy) and (z< > 5)
что меняем: and
чем заменить: &
результат
(x> 0) & (yy) & (z< > 5)
нужно сделать в python

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
akimovilya20
29.07.2020 23:38
Zoner Photo Studio 16 - універсальна професійна фотолабораторія, незамінний помічник на всіх етапах життєвого циклу цифрової фотографії, який відповідає як запитам фотографів, так і потребам великих компаній.
CrazyTalk Media Studio Edition 4.5 - новейша версія програми для "пожвавлення" звичайної фотографії.
ACDSee Photo Manager - це багатофункціональний інструмент для перегляду, конвертування, редагування, каталогізації, сортування, друку, публікації графічних зображень самих різноманітних форматів.
Nikon Capture - це потужне програмне забезпечення для редагування та обробки фотографій, відомого багатьом професіоналам і любителям по ранніх версіях, розробленого для знімають цифровою фототехнікою фотографів, незалежно від того, який формат вони використовують.
Brightness Guide - програма здатна висвітлити темні області на фотографії, залишаючи світлі області недоторканими.
Ulead PhotoImpact - набір програм професійного рівня для роботи з графікою.
0,0(0 оценок)
Ответ:
Analochka
17.03.2021 08:37
Const
  a1 = -0.3;
  a2 = 0.5;
  h = 0.1;
  nm = 50;

var
  b: array[1..nm] of real;
  x, y, min: real;
  i, n, imin: integer;

begin
  n := trunc((a2 - a1) / h + 1);
  x := a1; min := 1e20;
  for i := 1 to n do
  begin
    b[i] := x;
    y := x * sqr(x - 1) * (x - 2) * sqr(x - 2);
    if min > y then begin imin := i; min := y end;
    x := a1 + i * h
  end;
  Writeln('Минимальное значение ', min, ' достигнуто при аргументе ', b[imin])
end.

Результат выполнения программы:
Минимальное значение -0.746496 достигнуто при аргументе 0.2

Аналитическое решение показывает, что у функции имеется локальный минимум в точке x=(5-√13)/6≈0.2324081207; при этом функция принимает значение, приблизительно равное -0.7562371972, поэтому решение можно считать верным.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота