Nastya161003
05.03.2022 11:07

1)выяснить, есть ли в массиве строки, в которых буква а расположена справа от

буквы д (известно, что буква д в каждой строке единственная).

2) дан динамический массив целых чисел {ai} (i=1, 2, ), целое число k

(k > 0). осуществить циклический сдвиг значений компонентов массива в

право на 1 компонент. для обращение к элементам массива использовать

указатель

3) имеется множество, содержащее натуральные числа из диапазона [-

99..99]. сформировать два множества, первое из которых содержит все числа из

данного множества, которые делятся на 3 и 5, а второе — все составные.

4) дано слово. поменять местами его вторую и предпоследнюю буквы.

5) дано множество m, содержащее цветов {крокус: март-апрель,

нарцисс: апрель-май, лилия: июнь-июль, тюльпаны: апрель-май, гладиолус: августсентябрь} . написать программу, которая позволит пользователю вводит название

цветка и видеть период цветения.

6) дан массив целых чисел a. найти суммы положительных и отрицательных

элементов массива, используя функцию определения суммы.

p.s. программы должны быть на delphi!

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
dasha1949
17.10.2022 00:10

Для введення в форму даних, які можуть мати тільки одне з двох допустимих значень, призначені елементи управління CheckBox, або прапорці. Прапорці дозволяють користувачеві дати відповідь на поставлене запитання. У разі позитивної відповіді користувач встановлює прапорець, і він набуває вигляду квадрата, в якому розміщена галочка. При невстановленому прапорці він має вигляд порожнього квадрата, позначаючи негативну відповідь на поставлене запитання. Можливий ще один стан прапорця, при якому він не визначений. У цьому стані він має вигляд галочки на сірому тлі.

0,0(0 оценок)
Ответ:
a01065699799
22.07.2022 16:31

ответ:1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

var

 Chislo, Count, Summa, n: integer;

 

begin

 Summa := 0;

 Count := 0;

 readln(Chislo);

 while Chislo > 0 do

 begin

   n := Chislo mod 10;

   if odd(n) then  

   begin

     Summa := Summa + n;

     inc(Count);

   end;

   Chislo := Chislo div 10;

 end;

 writeln('Сумма  нечетных цифр числа: ', Summa);

 writeln('Кол-во нечетных цифр числа: ', Count);

 writeln('Среднее арифметическое  нечетных цифр: ', Summa / Count);

end.

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота