Есения816
17.04.2023 23:32

Напишите программу на pascalabc для решения : мальчик решил накопить деньги. в первый месяц он отложил a рублей, а каждый следующий месяц он откладывал на d рублей больше, чем в предыдущий. сколько рублей мальчик накопит за n месяцев? ​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
gambab
10.10.2020 14:58

Var  a, d, n, i, otv: integer;

begin

  read(a,d,n);                                - ввод всех значений

  otv:=a;                                        - в переменную где будет храниться

  for i:=1 to n do                              ответ записываем начальный взнос

  begin

     a:=a+d;                                     - увеличиваем в цикле взнос

     otv:= otv + (a);                         - добовляем взнос к нашему ответу

  end;

  writeln(otv);                                 - выводим ответ

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота