tolodono
21.07.2021 06:21

Составить программу для вычисления значения выражения. паскальаbc. ​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
dimitiy02
29.05.2020 12:37

program aaa;

const n=50;

var w, c, x, d10, d4, d1: integer;  

begin 

  writeln ('введите вес бандероли');

  readln (w);

  if w < = n

    then c: =10

    else  

        if w mod n = 0

          then c: =10+((w div n)-1)*5

          else c: =10+5+((w div n)-1)*5;

 

  d10: = c div 10;

  d4: = (c-10*d10) div 4;

  d1: = (c-d10*10-d4*4);

 

  writeln ('стоимость бандероли: ',c,' драхм');

  writeln;

  writeln ('для оплаты нужно не менее');

  writeln (d10: 10,' монет по 10 драхм');

  writeln (d4: 10,' монет по 4 драхмы');

  writeln (d1: 10,' монет по 1 драхме');

end.

результат работы программы:

введите вес бандероли       100

стоимость бандероли: 15 драхм

для оплаты нужно не менее

          1 монет по 10 драхм

          1 монет по 4 драхмы

          1 монет по 1 драхме

0,0(0 оценок)
Ответ:
tanyaanya200615
25.07.2021 19:40
var
  x: string;
  arr: array of char;

begin
  readln(x);
  arr := x.Split(' ')[1].ToCharArray();
  System.Array.Reverse(arr);
  writeln(length(arr), '   ', new string(arr));
end.

var
  c: array of integer := (10, 20, 10, 30, 40, 50, 55, 1, 5, 9, 4, 3, 2);
  r, q, s: real;
  i, a, b: byte;
  
begin
  q := 1;
  i := 1;
  r := c.Min();
  while (i < length(c)) do
  begin
    q *= c[i];
    i += 2;
  end;
  readln(a, b);
  s := b - a - 1;
  writeln('T = ', (R / Q + 1) + S);
end.

const
  k = 5;
  p = 5;

var
  f: array [1..k, 1..p] of string;
  o: real;
  df: byte;

begin
  for i: byte := 1 to k do
  begin
    for j: byte := 1 to p do
    begin
      f[i, j] := random(10, 99).ToString();
      write(f[i, j]:3);
      if (j >= 7 - i) then
      begin
        o += integer.Parse(f[i, j]);
        df += 1;
        f[i, j] := '██';
      end;
    end;
    writeln();
  end;
  writeln();
  for i: byte := 1 to k do
  begin
    for j: byte := 1 to p do
      write(f[i, j]:3);
    writeln();
  end;
  writeln(o / df);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота