Колобокхоёк
29.05.2020 08:22

Язык pascal.

вводится строка из трёх слов, разделённых пробелами. в начале и конце строки могут быть пробелы. составьте программу, преобразующую строку к верхнему регистру и удаляющую пробелы в начале и конце строки.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
vyaskin2018
10.10.2020 14:40

===== PascalABC.NET =====

begin

 var s := ReadlnString;

 s := Trim(s).ToUpper;

 s.Println

end.


Язык pascal.вводится строка из трёх слов, разделённых пробелами. в начале и конце строки могут быть
0,0(0 оценок)
Ответ:
alina067
16.01.2024 13:03
Хорошо, давай я разберу эту задачу пошагово и создам программу на языке Pascal, которая будет решать данную задачу.

1. Начнем со структуры программы. Создайте новый проект в среде разработки Pascal (например, Lazarus или Turbo Pascal) и назовите его "UpperCaseWithTrim".

2. Теперь, когда у нас есть пустой проект, мы можем приступить к написанию кода. Создайте переменные для хранения введенной строки и преобразованной строки. Также понадобятся переменные для указания начала и конца строки.

```pascal
program UpperCaseWithTrim;

var
inputString, outputString: string;
startIdx, endIdx: integer;
```

3. Теперь давайте обратимся к пользователю и запросим ввод строки. Мы можем использовать функцию ReadLn для чтения строки с клавиатуры. В результате пользовательский ввод будет сохранен в переменной inputString.

```pascal
begin
Write('Введите строку из трех слов, разделенных пробелами: ');
ReadLn(inputString);
```

4. Проверим, есть ли пробелы в начале строки. Мы можем использовать функцию Pos для этого. Если пробелы есть, мы будем искать индекс первого символа, не являющегося пробелом, и сохранять его в переменную startIdx.

```pascal
startIdx := 1;
while (startIdx <= Length(inputString)) and (inputString[startIdx] = ' ') do
Inc(startIdx);
```

5. Теперь проверим, есть ли пробелы в конце строки. Для этого мы просканируем строку с конца и найдем индекс последнего символа, не являющегося пробелом. Мы будем сохранять его в переменную endIdx.

```pascal
endIdx := Length(inputString);
while (endIdx >= 1) and (inputString[endIdx] = ' ') do
Dec(endIdx);
```

6. Перейдем к преобразованию строки к верхнему регистру и удалению пробелов в начале и конце строки. Мы будем использовать функции UpperCase и Copy для этого. UpperCase преобразует строку к верхнему регистру, а Copy создаст новую строку без пробелов по указанным индексам startIdx и endIdx.

```pascal
outputString := UpperCase(Copy(inputString, startIdx, endIdx - startIdx + 1));
```

7. Наконец, выведем преобразованную строку на экран.

```pascal
WriteLn('Преобразованная строка: ', outputString);
end.
```

Таким образом, вы получите программу на языке Pascal, которая будет преобразовывать введенную строку к верхнему регистру и удалять пробелы в начале и конце строки.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота