dianapodosenova
17.02.2020 03:35

Программа в c или c++
составить программу в котором содержится информация о группе с n количеством студентов
1. реализовать поиск студентов по возрасту.
2.с функции сделать замену записи самый маленький с самым большим возрастом.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
firsovata2017tatyana
01.01.2023 18:36
{ ответ дан на языке Pascal }
//1-ая задача
PROGRAM Solution(INPUT, OUTPUT);

VAR
  num: INTEGER;
  n1, n2, n3: INTEGER;

BEGIN
  WRITE('Введите 3-значное число: ');
  READ(num);

  n1 := (num DIV 100);
  n2 := (num MOD 100 MOD 10);
  n3 := (num MOD 100 DIV 10);
  IF(n1 + n2 + n3) MOD 2 = 0
  THEN WRITELN('Чётное')
  ELSE WRITELN('Нечётное');
END.

//2-ая задача
PROGRAM Solution(INPUT, OUTPUT);

VAR
  num: INTEGER;
  n1, n2, n3: INTEGER;

BEGIN
  WRITE('Введите 3-значное число: ');
  READ(num);

  n1 := (num DIV 100);
  n2 := (num MOD 100 MOD 10);
  n3 := (num MOD 100 DIV 10);
  IF(num * num) = (n1 * n1 * n1) + (n2 * n2 * n2) + (n3 * n3 * n3)
  THEN WRITELN('Равен')
  ELSE WRITELN('Не равен');
END.

//3-я задача
PROGRAM Solution(INPUT, OUTPUT);

VAR
  a, b, c: INTEGER;

BEGIN
  WRITE('Введите a, b, c: ');
  READ(a, b, c);

  IF(a = b) OR (b = c) OR (c = a)
  THEN WRITELN('Равнобедренный')
  ELSE WRITELN('Не равнобедренный');
END.
0,0(0 оценок)
Ответ:
Kotvo4cah
01.01.2023 18:36

Первая

var n,x:integer;

begin

 readln(n);

 while n <> 0 do begin

  x:=x + n mod 10;

  n:=n div 10;

 end;

 if(x mod 2 = 0) then

   writeln('true')

 else

   writeln('false');

end.

Вторая

var x,z,s:integer;

begin

 readln(x);

 if (x > 99) and (x < 1000) then begin

   s:=x;

   while s<>0 do begin

     z:=z+s mod 10;

     s:=s div 10;

   end;

   if(x*x) = (z*z*z) then

     writeln('true')

   else

     writeln('false');

 end

 else

   writeln('Число должно быть 3-ех значным!');

end.

Третья

Var a,b,c:Real;  

Begin  

 Writeln('Введите a');

 Readln(a);

 Writeln('Введите b');

 Readln(b);

 Writeln('Введите c');

 Readln(c);

 if (a=b) or (a=c) or (b=c) then

   writeln ('true')

 else

   writeln ('false);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота