jasmin47
03.12.2021 23:30

Написать программу на c#
удалить часть символьной строки, заключенной в скобки (вместе со скобками).

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
yanachor25
11.04.2022 06:56
1. Вот так это пишется с функцией

// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
function IsPrime(n:integer):boolean;
begin
  if n<4 then Result:=True
  else begin
    var found:= (n mod 2 = 0);
    var p:=3;
    while (not found) and (sqr(p)<=n) do
      begin
      found:=(n mod p = 0);
      p+=2
      end;
    Result:=not found
    end
end;

begin
  Writeln('k=',ArrRandom(ReadInteger('n='),1,999).Println.
    Where(x->IsPrime(x)).Count)
end.

Тестовое решение:
n= 10
401 828 780 444 694 965 23 341 673 875
k=3

2. А вот так это пишется с процедурой

// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
procedure IsPrime(n:integer; var res:boolean);
begin
  if n<4 then res:=True
  else begin
    var found:= (n mod 2 = 0);
    var p:=3;
    while (not found) and (sqr(p)<=n) do
      begin
      found:=(n mod p = 0);
      p+=2
      end;
    res:=not found
    end
end;

begin
  var a:=ArrRandom(ReadInteger('n='),1,999); a.Println;
  var k:=0;
  var prime:boolean;
  foreach var e in a do begin
    IsPrime(e,prime);
    if Prime then Inc(k)
    end;
  Writeln('k=',k)
end.

Тестовое решение:
n= 12
199 43 71 365 417 904 170 212 694 103 161 689
k=4
0,0(0 оценок)
Ответ:
Alexandra1031
15.05.2023 14:42
Так как каждая сеть должна адресовать не менее 2000 узлов, последнее число может быть любым (256 вариантов). На 2-ом справа числе должна быть маска так, чтобы была свобода хотя бы в 8 номеров (256*8=2048).
Но при этом чтобы все три адреса попали в три разных сети.
Второе число должно быть 11111000(2) = 248(10).
1 сеть будет от 192.168.176.1 до 192.168.183.254 - в ней 192.168.181.171.
2 сеть будет от 192.168.160.1 до 192.168.167.254 - в ней 192.168.165.80
3 сеть будет от 192.168.168.1 до 192.168.175.254 - в ней 192.168.173.134.
ответ: 255.255.248.0 для всех трех сетей.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота