yfjfufnfkdm
30.05.2020 09:40

Составьте схему алгоритма и напишите программу для вычисления значения функции y.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
AliceWhite31841
03.04.2020 14:49

Промышленные роботы дают возможность автоматизировать все виды операций. Сфера применения довольно широка: заготовительное производство, механообработка, сварочное производство, сборочное производство, термообработка, гальванические и лакокрасочные покрытия, транспортно-накопительные системы. В обрабатывающей промышленности отрасли лидеры по покупкам роботов не меняются уже более пяти лет: это автомобильная промышленность и электроника.

Роботы применяются практически во всех отраслях промышленности, их целесообразность применения диктуется прежде всего интересами человека, удобством и безопасностью работы.

Самая важная роль отводится роботам, заменяющим человека при выполнении различных задач в экстремальных условиях: на больших глубинах, в вакууме, в космосе, на участках с радиационно- взрыво- и пожароопасными условиями, а также на химических и фармацевтических производствах. 

0,0(0 оценок)
Ответ:
Fidjit
22.11.2022 17:52
// PascalABC.NET 3.1, сборка 1179 от 29.02.2016
procedure GetProdNeg(a:array of integer; var p:real);
// произведение отрицательных элементов
begin
  p:=a.Where(x->x<0).Aggregate(1.0,(p,e)->p*e)
end;

function IsPrime(n:integer):boolean:=
  Range(2,Round(sqrt(n))).All(i->n mod i<>0);

procedure ArrPrime(n:integer; var a:array of integer);
// массив простых чисел не больших n
begin
  a:=Range(2,n).Where(i->IsPrime(i)).ToArray
end;

begin
  var n:=ReadInteger('n=');
  var a:=ArrRandom(n,-50,50); a.Println;
  var r:real;
  GetProdNeg(a,r);
  Writeln('Произведение ',r);
  n:=ReadInteger('n=');
  var b:array of integer;
  ArrPrime(n,b);
  b.Println
end.

Тестовое решение:
n= 15
27 -7 -36 40 -15 -21 -47 -28 -12 45 3 -38 -15 1 -39
Произведение 27866837980800
n= 300
2 3 5 7 11 13 17 19 23 29 31 37 41 43 47 53 59 61 67 71 73 79 83 89 97 101 103 107 109 113 127 131 137 139 149 151 157 163 167 173 179 181 191 193 197 199 211 223 227 229 233 239 241 251 257 263 269 271 277 281 283 293
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота