Даша12345н
09.07.2022 11:46

40 напишите программу которая запрашивает количество элементов линейного массива действительных чисел (не больше 25), затем сами элементы массива, затем выводит на экран введённый массив( на одной строке) и на следующей строке два его наибольших из положительных членов( одинаковые члены игнорируются - то есть из массива -3 3 2 1 1 будут выведены числа 3 и 2). если таких членов в массиве нет, программа сообщает об этом (40 )

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
EgorT222
23.11.2022 23:46
#include <iostream>#include <ctime>//Бібліотека для рандомуusing namespace std;int main(){ int array[10];//Масив int Max_Num=0,Min_Num=0;// Мінімальне і Максимальне числа bool Positive_or_negative=0;//Число додатнє чи відємне srand(time(NULL));//Рандом.Кожний раз інший. for(int i=0;i<10;++i) { Positive_or_negative=rand()%2; if(Positive_or_negative==false)//якщо Positive_or_negative==0 { array[i]=-(rand()%10);//Рандом від -10...0 } else { array[i]=rand()%10;//Рандом від 0...10 } if(array[i]>Max_Num)//Пошук макс. числа { Max_Num=array[i]; } if(array[i]<Min_Num)//Пошук Мін. числа { Min_Num=array[i]; } cout<<array[i]<<" "; } cout<<endl<<"Max. number is:"<<Max_Num<<endl;//Вивід максимально числа cout<<"Min. number is:"<<Min_Num<<endl;//Вивід мінімально числа system("pause>>void");//закінчення программи.}
0,0(0 оценок)
Ответ:
Ксюнька1801
02.10.2020 10:38

import random

N = [random.randint(0, 100) for i in range(10)]

print ("Array is:", N)

sum_less_50 = 0

Count_less_50 = 0

sum_more_50 = 0

Count_more_50 = 0

for elem in N:

   if elem >= 50:

       Count_more_50 += 1

       sum_more_50 += elem

   else:

       Count_less_50 += 1

       sum_less_50 += elem

print("Awerage of nums, that < 50: ", end = "")

if Count_less_50 > 0:

   print(sum_less_50 / Count_less_50)

else:

   print(0)

print("Awerage of nums, that >= 50: ", end= "")

if Count_more_50 > 0:

   print(sum_more_50 / Count_more_50)

else:

   print(0)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота