sviridov971
17.12.2022 00:38

Напистаь программу в турбо паскале

дан массив a размерностью n (размерность вводит пользователь). массив заполнен случайными числами от -9 до 28. написать программу, сортирующую массив по возрастанию.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
alina200120
10.10.2020 13:09

program delin;

const

 nn = 100;// максимальный размер массива

var

 i, j, n, t: integer;

 a: array[1..nn] of integer;

begin

 write('n = ');

 read(n);

 randomize;

 for i := 1 to n do

 begin

   a[i] := random(38) - 9;

   write(a[i], ' ');

 end;

 writeln;

 for i := n - 1 downto 1 do

   for j := 1 to i do

     if a[j] > a[j + 1] then

     begin

       t := a[j];

       a[j] := a[j + 1];

       a[j + 1] := t;

     end;

 for i := 1 to n do

   write(a[i], ' ');

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота