onlysvp
21.05.2020 17:17

Нужно составить программу pascal, в которой вводятся интервалы двух отрезков и число х. программа должна определять какому отрезку принадлежит это число. без использования and и or​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
5ти
05.05.2020 14:59

Объяснение:

program kek;

var

 l1, r1, l2, r2, x: Integer;

begin

 read(l1, r1, l2, r2, x);

 if ((x-l1)*(r1-x) >= 0) then writeln('Первый отрезок.');

 if ((x-l2)*(r2-x) >= 0) then writeln('Второй отрезок.');

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота