umma95
28.05.2023 16:30

Письменно составить программу для робота построения первой буквы имени (первая буква имени к)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Markys1555
03.03.2021 06:36
/*
Найти частное от деления нацело
используя только + и -
*/

#include <iostream>
using namespace std;

int main()
{
int a, b;
cout <<"Введите два целых числа: ";
cin >>a >>b;
int c=0;
while(a>=b)
{
a-=b;
c++;
}
cout <<"Частное равно " <<c <<endl;

return 0;
}

/*
Определение среднего роста учащичся
*/
#include <iostream>
using namespace std;

int main()
{
cout <<"Введите количество учащихся: ";
int cnt;
cin >>cnt;
cout <<"Ведите рост каждого из " <<cnt <<" учащихся:" <<endl;
int length=0, l;;
for(int i=0; i!=cnt; ++i)
{
cin >>l;
length+=l;
}
float avg=1.0*length/cnt*1.0;
cout.setf(std::ios::fixed);
cout.precision(2);
cout <<"\nСредний рост: " <<avg <<endl;

return 0;
}
0,0(0 оценок)
Ответ:
kashlakova20031
03.03.2021 06:36

1)

var

  a, b, s : real;

begin

  read (a, b);

  s := a * b;

  write (s:10:4);

end.

 

2)

var

  a, b, c, k : integer;

begin

  read (a, b, c);

  k := 0;

  if a > 0 then inc (k);

  if b > 0 then inc (k);

  if c > 0 then inc (k);

  writeln (k);

end.

 

3)

var

  a : integer;

begin

  read (a);

  writeln ((a mod 10) * (a mod 100 div 10) * (a div 100 mod 10) * (a div 1000));

end.

 

4)

var

  c, n : integer;

begin

  read (n);

  c := 0;

  repeat

    inc (c);

    n := n div 10;

  until n = 0;

  writeln (c);

end.

 

5)

var

  n, sum, i : integer;

begin

  read (n);

  sum := 0;

  for i := 1 to n do

    sum := sum + i;

  writeln (sum);

end.

 

6)

var

  d, n, k : integer;

begin

  read (n, k);

  d := 0;

  while n >= k do

  begin

    d := d + 1;

    n := n - k;

  end;

  writeln ('n div k = ', d);

  writeln ('n mod k = ', n);

end.

 

7)

var

  n, sum, i, tmp : integer;

begin

  read (n);

  sum := 0;

  for i := 1 to n do

  begin

    read (tmp);

    sum := sum + tmp;

  end;

  writeln (sum / n);

end.

 

8)

var

  i, n, s : integer;

  a : array [1..1000] of integer;

begin

  s := 2;

  read (n);

  for i := 1 to n do

  begin

    a[i] := s;

    s := s + 2 * i + 1;

  end;

  for i := 1 to n do write (a[i], ' ');

end.

 

9)

var

  n, i, count, tmp : integer;

begin

  read (n);

  count := 0;

  for i := 1 to n do

  begin

    read (tmp);

    if tmp < 0 then inc (count);

  end;

  writeln (count);

end.

 

10)

var

  n, i, j : integer;

begin

  read (n);

  for i := 1 to n do

  begin

    for j := 1 to i do

      write ('*');

    writeln;

  end;

end.

 

11) //Не понял, как заполняется массив? Тут рандом

var

  a : array [1..1000] of integer;

  i, n : integer;

begin

  read (n);

  for i := 1 to n do

    a[i] := trunc (random (1000)) - 500;

  for i := 1 to n do

    if a[i] > 0 then a[i] := a[i] * (-1)

   else if a[i] < 0 then a[i] := sqr (a[i]);

  for i := 1 to n do

    write (a[i], ' ');

end.

 

12)

var

  n, i, count : integer;

begin

  read (n);

  count := 0;

  for i := 1 to n do

    if n mod i = 0 then inc (count);

  writeln (count);

end.

 

  

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота