kamfetisova201
06.02.2023 10:38

Написать программу, которая :
1) заполнит массив случайными вещественными числами в диапазоне от - 20,3 до 15,75.
2) выведет массив в поле memo
3) из всех положительных элементов массива вычтет элемент с номером k , из отрицательных число m, нулевые элементы оставит без изменений.
- полученный массив выведет в другое поле memo
числа k, m вводятся в поля edit.​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Ответ:
bella77777
19.05.2022 21:59

#Python 3.8.3

from typing import *

def FindFirstIndex(source: Iterable[Any], predicate: Callable[[Any], Any]):

   for index, item in enumerate(source):

       if (predicate(item)):

           return index

def main():

   arr = [1, 2, 3, 4, 5, -1, 2, -4]

   firstOdd = FindFirstIndex(arr, lambda p: p % 2 != 0)

   firstNegative = FindFirstIndex(arr, lambda p: p < 0)

   arr[firstOdd], arr[firstNegative] = arr[firstNegative], arr[firstOdd]

   print(arr)

if __name__ == '__main__':

   main()

Объяснение:

0,0(0 оценок)
Ответ:
ukrainahfy
24.04.2023 12:44
Растровое изображение представляет из себя:
✔ мозаику из очень мелких элементов — пикселей;
сочетание примитивов (это про векторное изображение);
палитру цветов.

Растровое графическое изображение формируется из:
линий
✔ пикселей
графических примитивов (это про векторное изображение)

В векторной графике изображения строятся из:
пикселей (это про растровую графику);
✔ примитивов;
рисунков.

Эффективно представляет изображения фотографического качества:
векторная графика;
✔ растровая графика.

Относительно небольшой объём памяти занимают:
✔ векторные рисунки; (это как правило верно. Но если пытаться делать изображения фотографического качества в векторной графике, файлы будут получаться огромными)
растровые изображения.

Могут быть легко масштабированы без потери качества:
✔ векторные рисунки;
растровые изображения.

Растровое графическое изображение получается:
✔ в процессе сканирования (в остальных случаях - векторная)
при работе с системами компьютерного черчения
при создании рисунка в MS Word

Какой тип графического изображения вы будете использовать при редактировании цифровой фотографии?
✔ растровое изображение
векторное изображение

Что можно отнести к достоинствам растровой графики по сравнению с векторной?
Малый объём графических файлов. (это про векторную)
✔ Фотографическое качество изображения.
Возможность просмотра изображения на экране графического дисплея. (это верно для любой компьютерной графики)
Возможность масштабирования изображения без изменения его качества. (это про векторную)

Файлы, с какой графикой имеют наибольший размер?
✔ Растровой.
Векторной.
Трёхмерной. (обычно простенькая трехмерная графика составляется из примитивов и имеет небольшой размер. Но опять-таки, если ставить целью добиться максимальной естественности изображения, то здесь будет максимальный размер) 

Изображения, какой графики состоят из массива точек (пикселей)?
✔ Растровой.
Векторной
Трёхмерной

Для хранения растрового изображения размером 64 на 64 пикселя отвели 512 байтов памяти. Каково максимально возможное число цветов в палитре изображения?
Всего пикселей 64 * 64 = 2^12, на них отводится 512 байт = 2^9 байт = 2^12 бит. Тогда на 1 пиксель отводится всего 1 бит, и в палитре не больше 2^1 = 2 цветов.

В процессе преобразования растрового графического файла количество цветов уменьшилось с 512 до 8. Во сколько раз уменьшился информационный объем файла?
512 = 2^9, 8 = 2^3. В первом случае на 1 пиксель отводится 9 бит, во втором - 3 бита. Размер уменьшился в 3 раза.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота