Мαлинкα
17.09.2020 10:05

Написать программу которая рассчитывает 10!
использовать цикл с параметром ( счётчиком) и цикл с предусловием.
большое

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
TRIPLEN
10.10.2020 12:02

Program fact10;

var

i:byte;

fact:longint;

begin

writeln('Цикл с параметром');

fact:=1;

for i:=2 to 10 do

fact:=fact*i;

writeln('10! = ',fact);

writeln('Цикл с предусловием');

fact:=1;

while (i<>1) do

begin

fact:=fact*i;

i:=i-1;

end;

writeln('10! = ',fact);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота