marypawgamesyt
09.03.2023 23:02

Составить программу, определяющую, попадает ли точка с заданными координатами x и y в закрашенную область (использовать формулы уравнения прямой, проходящей через две точки, уравнения окружности, уравнения прямых, параллельных осям координат). результат работы программы вывести в виде текстового сообщения. (параметры r, r1, r2, a, b,с вводятся с клавиатуры.) - если имеются

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
nomerperv
11.08.2020 17:52

отправь нарушение ошипся я не знаю

0,0(0 оценок)
Ответ:
encl3
11.08.2020 17:52

var

 x, y, r: real;

begin

 read(x, y, R);

 if (x * x + y * y <= R * R) or

   (y <= 0) and (y >= -2 * x) and (y >= 2 * (x - R)) then

   write('попадает')

 else

   write('не попадает');

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота