peindragneel11
06.01.2021 13:00

Составить программу веера из 10 лепестков, смотрящие вверх​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
dimа11
08.05.2023 18:36

Для начала найдем, сколько информации несет каждый символ: мощность алфавита 256, находим количество информации по формуле N = 2i, где N - мощность алфавита, i - количество информации в битах, которое несет каждая буква.

256 = 28, значит каждый символ несет 8 бит информации, или 1 байт.

2. В одной строчке 70 символов, значит, 70 * 1 = 70 байт несет каждая строчка.

3. На одной странице 30 строк, поэтому 30 * 70 = 2100 байт несет каждая страница.

5. Пять страниц текста содержит 2100 * 5 = 10500 байт информации.

ответ: 10500 байт.

0,0(0 оценок)
Ответ:
ксения1373
10.07.2021 10:05

const

 n = 15;

var

 x: array[1..n] of integer;

 i, k, t, min: integer;

begin

 Randomize;

 Writeln('Исходные элементы массива');

 min := 1000;

 for i := 1 to n do

 begin

   x[i] := Random(101) - 50;

   Write(x[i]:4);

   if min > x[i] then begin

     min := x[i];

     k := i

   end

 end;

 t := x[k]; x[k] := x[1]; x[1] := t;

 Writeln;

 Writeln('Результирующие элементы массива');

 for i := 1 to n do Write(x[i]:4);

 Writeln

end.

Исходные элементы массива

-28 -22 -15   3  27  29  34 -29 -49 -37 -19  31  40 -36   4

Результирующие элементы массива

-49 -22 -15   3  27  29  34 -29 -28 -37 -19  31  40 -36   4

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота