sonykit2006
05.07.2021 11:00

Нужно написать программу на паскале для просчёта траектории орбитальной станции, летящей вокруг земли
входные параметы, это её скорость, масса и высота над землёй
в качестве выходного значения нужно написать, что лучится со станцией через 5 часов: она улетит с орбиты, останется на орбите, или упадёт на землю
я сам знаю плохо, что делать не знаю, но за решение полагается 2 пятёрки

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
greennattea
03.07.2022 11:46
import java.util.Scanner;

/**
* Created by Geek on 20.09.2016.
*/
public class getTime {
public static void main(String[] agrs){
Scanner in = new Scanner(System.in); // Создаем объект ввода через консоль
System.out.print("Сколько минут после начала дня:");
int n = in.nextInt();
if(n <= 59) {
System.out.print(String.format(" часов и %d минут",n));
} else if(n > 1440) {
n = n - ((n/1440)*1440);
System.out.print(String.format(" часиков и %d минут",n/60,n%60));
} else {
System.out.print(String.format(" часиков и %d минут",n/60,n%60));
}

}
}
0,0(0 оценок)
Ответ:
СвятойТапочек
03.07.2022 11:46
import java.util.Scanner;

/**
* Created by Geek on 20.09.2016.
*/
public class getTime {
public static void main(String[] agrs){
Scanner in = new Scanner(System.in); // Создаем объект ввода через консоль
System.out.print("Сколько минут после начала дня:");
int n = in.nextInt();
if(n <= 59) {
System.out.print(String.format(" часов и %d минут",n));
} else if(n > 1440) {
n = n - ((n/1440)*1440);
System.out.print(String.format(" часиков и %d минут",n/60,n%60));
} else {
System.out.print(String.format(" часиков и %d минут",n/60,n%60));
}

}
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота