Ffffffsusjbshjxj
02.02.2020 09:36

Нужно написать программу с языка программирования visual basic.

дана матрица (5*3)

a. поменять местами элементы первого и последнего столбцов.

b. найти скалярное произведение элементов 1-го и последнего столбца. использовать форму.
100 !

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
whitezizickela
22.10.2021 15:59
При́судок (від чеськ. přísudek)[1] — головний член речення, пов'язаний координацією з підметом, що виражає дію предмета, названого підметом. Найтиповіша форма присудка — дієслово в особовій формі, що означає дію чи стан суб'єкта, названого підметом. Присудок — головний член двоскладного речення, що характеризує підмет за дією чи ознакою. Присудок відповідає на питання що робить? що зробить ? що з ним робиться? у якому він стані? який він є? хто або що він є? При схематичному аналізі речення графічно позначається підкреслюванням двома рисками.
0,0(0 оценок)
Ответ:
MariaVay000
22.04.2022 13:49
Var s,st: string;
    a: array[1..255] of integer;
    i: integer;    
begin
  write('строка: ');  readln(s);
  for i:=1 to 255 do a[i]:=0;
  for i:=1 to length(s) do inc(a[ord(s[i])]);
  st:='';
  for i:=1 to length(s) do
    if ((a[ord(s[i])]>=2) and
       (s[i] in ['а'..'я']))  then continue
    else st:=st+s[i];
  writeln('новая строка: ',st);
end.

строка: Это строка для проверки.
новая строка: Э са для пвеи.

Если нужно, чтобы не различались прописные и строчные буквы, то другой вариант программы:

var s: string;
    a: array[1..255] of integer;
    i,j: integer;    
begin
  write('строка: ');  readln(s);
  for i:=1 to 255 do a[i]:=0;
  for i:=1 to length(s) do
  if ord(s[i])>32 then
  begin
    inc(a[ord(s[i])]);
    if s[i] in ['а'..'я'] then inc(a[ord(UpperCase(s[i]))])
    else if s[i] in ['А'..'Я'] then inc(a[ord(LowerCase(s[i]))]);
  end;  
  j:=0;
  for i:=1 to length(s) do
  if (a[ord(s[i])]>=2) then continue
  else 
  begin
    inc(j);
    s[j]:=s[i];
  end;  
  delete(s,j+1,length(s)-j);
  writeln('новая строка: ',s);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота