милка578
26.05.2023 13:12

Практикум n 2 «формирование массивов». вариант 1.
• составить программу к решению : «сформировать массив из n
элементов: 5 0 5 0..».
• составить программу к решению : «сформировать массив из
степеней числа 2 с первой по десятую степень».
• составить программу к решению : «дан массив а. сформировать
массив в, выбросив из а каждый второй элемент».
составить программу к решению : «дан одномерный массив и
число k. заменить каждый его элемент, меньший числа k, числом a[i]*k
и вывести массив.​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Kirill15003
28.11.2021 19:14

Проходим по строке, запоминая текущий символ и сколько раз он уже повторился. Если следующий символ такой же, то просто увеличиваем длину серии на 1, если нет - выводим информацию про серию и начинаем новую. Надо не забыть корректно обработать последний символ - после него серия также заканчивается.

Код (Python 3):

s = input()

current_digit, count = None, 0

for digit in s:

   if current_digit != digit:

       if count > 0:

           print(count, current_digit)

       current_digit, count = digit, 1

   else:

       count += 1

print(count, current_digit)

0,0(0 оценок)
Ответ:
Alinalime10
28.11.2021 19:14

Проходим по строке, запоминая текущий символ и сколько раз он уже повторился. Если следующий символ такой же, то просто увеличиваем длину серии на 1, если нет - выводим информацию про серию и начинаем новую. Надо не забыть корректно обработать последний символ - после него серия также заканчивается.

Код (Python 3):

s = input()

current_digit, count = None, 0

for digit in s:

   if current_digit != digit:

       if count > 0:

           print(count, current_digit)

       current_digit, count = digit, 1

   else:

       count += 1

print(count, current_digit)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота