bebe9
18.10.2020 12:21

Написать программу для нахождения арифметического выражения x2-1=0

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
nazirakmtv
04.01.2023 07:37

import java.util.Scanner;

public class Main {

   public static void main(String[] args) {

       double Ax, Bx, Cx;

       Scanner sc = new Scanner(System.in);

       try {

           System.out.println("Waiting for input A, B and C...");

           Ax = sc.nextDouble();

           Bx = sc.nextDouble();

           Cx = sc.nextDouble();

           if (!(Cx > Math.min(Ax, Bx) && Cx < Math.max(Ax, Bx))) {

               System.out.println("Неверные входные данные.");

               return;

           }

           double AC = Math.abs(Cx - Ax);

           double BC = Math.abs(Cx - Bx);

           System.out.println("AC = " + AC);

           System.out.println("BC = " + BC);

           System.out.println("AC * BC = " + AC * BC);

       } catch (RuntimeException e) {

           System.out.println("Неверные входные данные.");

       }

   }

}

Проблемы, вопросы или предложения по работе программы в комментарии.

0,0(0 оценок)
Ответ:
osapkina
19.05.2021 12:38
1) Это явно шифр замены. Мы знаем, что:
А = Я, Н = С, Т = М, О = Р, М = Т, И = Ц, Х = Й, Л = У, Ь = Г,
Е = Ъ, В = Э, Г = Ь, Й = Х.
Этого достаточно, чтобы подставить буквы и получить
НМЪПЯС = СТЕ*АН, очевидно, что это СТЕПАН.
А если немного подумать, то можно догадаться, какой это шифр.
Взяли алфавит и написали два раза - прямо и наоборот.
Каждая буква из 1 алфавита заменяется на букву 2 алфавита.
А = Я, Б = Ю, В = Э, Г = Ь, и так далее.

2) Про Виталия. Из 96 друзей 76 знают Павла и 56 знают Андрея.
Значит, минимум 76+56-96 = 36 чел знают и Павла и Андрея.
Про Павла. Из 162 друзей 96 знают Андрея и 76 знают Виталия.
Минимум 96+76-162 = 10 знают и Андрея и Виталия.
Про Андрея. Из 108 друзей 56 знают Виталия и 96 знают Павла.
Минимум 56+96-108 = 44 знают и Виталия и Павла.
Выбираем наибольшее из минимальных чисел.
ответ: минимум 44 чел знакомы со всеми тремя парнями.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота