misik1
16.11.2020 20:24

Информатика напишите программу

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
KriStiNaTim03
03.11.2021 07:31
Допустим у тебя дано число 1001101 (в бинарной си), чтобы перевести ее в десятичную си нужно:
1) Расставить коэффициенты 0,1,2,3 начиная с последней цифры в двоичной записи. В итоге у тебя получаться такие коэффициенты над числами: 1^6, 0^5, 0^4, 1^3, 1^2, 0^1, 1^0.
2) Теперь умножим каждое число в бинарной си на основание двоичной си (двойка) в той степени, которой ты посчитал.
Т.е.: 1*2^6, 0*2^5 и так  далее.
3) Затем остается только сложить полученные числа из второго шага и ты получишь число в десятичной си
0,0(0 оценок)
Ответ:
AlexandroGuerin
24.04.2022 06:34
#include <iostream>

using namespace std;

int main()
{
    setlocale(LC_ALL,  "Russian");

    int A,B,C;
   
    while (1)
    {
        cout << "Первая сторона:";
        cin >> A;
       
        cout << "Вторая сторона:";
        cin >> B;
       
        cout << "Третья сторона:";
        cin >> C;

        if (A < 1 || B < 1 || C < 1)
        {
            cout << "Длина стороны должна быть больше 0\n";
        }
        else
        {
            if (A == B == C)
            {
                cout << "Равносторонний треугольник\n";
            }
            else if (A == B || A == C || B == C)
            {
                cout << "Равнобедренный треугольник\n";
            }
            else
            {
                cout << "Разносторонний треугольник\n";
            }
        }
    }

    return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота