LORDI9999
18.06.2020 01:21

Напишите программу, которая считывает реплики пользователя, пытается осмыслено реагировать на них, задавать вопросы, и заканчивает работу, только если пользователь попрощается.

чем больше будет тем, на которые сможет говорить бот, чем качественнее будут его ответы и анализ реплик пользователя — тем лучше.

обязательно на питоне

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
mam1975
14.05.2022 07:03

Программа:

Python:

import turtle

# большой круг (нижний):

turtle.color("black") # устанавливаем цвет  

turtle.penup() # поднимаем курсор

turtle.goto(0, -100) # переходим по координатам

turtle.pendown() # опускаем курсор

turtle.circle(90) # рисуем круг с радиусом 90

# средний круг(посредине):

turtle.color("black")  

turtle.penup()  

turtle.goto(0, 80)  

turtle.pendown()  

turtle.circle(60)

# маленький круг (верхний):

turtle.color("black")

turtle.penup()

turtle.goto(0, 200)  

turtle.pendown()

turtle.circle(35)

 

turtle.done()

0,0(0 оценок)
Ответ:
fgf14
28.04.2023 07:52

Программа:

Python:

№1)

arr = []

n, j = int(input()), 0

while n != 0:

   arr.append(n)

   n = int(input())

for i in arr:

   if i > (sum(arr)/len(arr)):

       j += 1

print(f'{arr}\n{j}')

№2)

from random import randint

arr = [randint(-100, 100) for i in range(10)]

print(arr)

summ = 0

for i in range(10):

   n = int(input())

   arr.append(n)

   summ += n

print(arr)

for i in arr:

   if i > summ: print(i, end=' ')

№3)

from random import randint

N = int(input('N = '))

arr = [randint(-100, 100) for i in range(N)]

print(arr)

for i in range(N):

   j = int(input())

   arr.append(j)

print(arr)

razn, summ = max(arr) - min(arr), 0  

for i in arr:

   if i > razn:

       summ += i

print(summ)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота