Pro1008700
16.10.2020 12:37

Напишите программу:
переставить элементы массива в обратном порядке (выполнить реверс). на языке паскаля

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
lari09vasiljeva
19.11.2022 18:46

Объяснение:

Задача 17.28

from random import *

n=int(input('Введите n :'))

p=int(input('Введите p :'))

k1=int(input('Введите n :'))

k=[0]*n

a1=0

a2=0

a3=0

for i in range (0, n):

 k[i] = randint(0, 101)

 if k[i]>p:

  a1+=1

 if k[i]%k1==0:

   a3+=1

 s=str(k[i])

 if s[len(s)-1]=='5':

   a2+=1  

   

print(k)

print('a)', a1)

print('б)', a2)

print('в)', a3)

Задача 7.43

from random import *

n=9

k=[0]*n

b=0

c=0

for i in range (0, n):

 k[i] = randint(1, 101)

 a = randint(1, 20)

 k[i] = k[i]/a

 if k[i]>10:

     b=b+ k[i]

     c+=1

   

print(k)

print('Среднее арифметическое чисел > 10   = ', b/c)

0,0(0 оценок)
Ответ:
Sagidanovadi
19.11.2022 18:46

Рассмотрим задачи последовательно

Объяснение:

Задача 1.

Спросим все параметры, запишем операнды в список с list comprehensions.

Далее в цикле для каждого элемента спросим, подходит ли он по условию, в зависимости от результата увеличим соответствующие счетчики.

Выведем всю нужную информацию, используя f-строки.

Задача 2.

Введем все числа в список сразу в числовом типе float. Далее отфильтруем их, используя описанную функцию is_right(). Выведем сумму элементов деленную на длину получившегося списка clear_list.


с решениями двух задач !
с решениями двух задач !
с решениями двух задач !
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота